View Options: Resolving a conflict

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

DJSimonmurray

New member
Joined
Nov 8, 2015
Messages
8
Points
1
Hi All,

Trust that you are keeping safe during these difficult times.

Quick query on Music layout when viewing by either ‘Artists’ or ‘Albums’ from the navigation panel to the left.

If I go into Albums first. Select view and show view options – Artist and then Year. Groups Artists and then the order albums were released, earliest first and then the latest as I scroll down.

This is the format I would like.

However, I would like the same layout when I select “Artists” from the side column. Instead what I get is the albums listed alphabetically when viewing in artist mode. When I change this to view by year in Artists in then alters the view in Alums tab on the side panel to showing them alphabetically and not as per year like I would like.

In essence, once I change one or other view option in ether Artists or Albums in the side panel to “artist and then year”, it does Artist year for one and artist and album by alphabet for the other.

See attached screenshots using AC/DC as an example.

Any way to correct to get to the way I want?

Thank You

Simon.
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,672
Points
48
Location
Arizona
It seems that you are using Grid view in the Albums section. That allows the Album order to be Artist and year.

In the Artist section, you are limited to List view, so you don't get the options you want. On top of that, the list view is broken when sorting by year. It just doesn't work. Even if you go into the Album section, use List view and tell it to sort by year it does not work.

What I found is that if I set the Albums to sort by Artist then Year, and then go to the Artists section, it is currently sorted by Artist (default) and year because of the Album setting.

So the fix is: don't set a sort in the Artists section, only set it in the Albums section.
 

DJSimonmurray

New member
Joined
Nov 8, 2015
Messages
8
Points
1
It seems that you are using Grid view in the Albums section. That allows the Album order to be Artist and year.

In the Artist section, you are limited to List view, so you don't get the options you want. On top of that, the list view is broken when sorting by year. It just doesn't work. Even if you go into the Album section, use List view and tell it to sort by year it does not work.

What I found is that if I set the Albums to sort by Artist then Year, and then go to the Artists section, it is currently sorted by Artist (default) and year because of the Album setting.

So the fix is: don't set a sort in the Artists section, only set it in the Albums section.
Thank you, your help is very much appreciated. How do i remove completely 'sort' in the Artists section within Music on the MAC. by default it seems to be sorting as title but can you remove sort completely and have no option? Thanks, Simon.
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,672
Points
48
Location
Arizona
I was using Windows when I saw my behavior. There I found my iTunes to sort the Artists section by year when I set Albums to Artists and Year.

On the Mac, there is no iTunes for me, but the Music App. There I can sort the Albums section by Artists and Year. Then if I look at the Artists section it is sorted by Title. Changing the Artists section to sort by year does it properly but the Albums section then changes to sort by Year then Title.

Not good for you. You'll apparently need to change the sorting each time you change section. No way to change iTunes or the Music app.
 
Top