turning off iMessages doesn't work

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

gib65

Member
Joined
Nov 13, 2009
Messages
44
Points
8
Hello,

I have a iphone 10 and I'm stuck on iMessages. I want to turn iMessages off because I'm out of data for the month but when I turn iMessages off in settings, every conversation I've had with iMessages stays on iMessages. I have no way of switching them to regular text messages. I was trying to text my son while I was away from home and I couldn't do it. The guy at the Apple store didn't know how to do it either. He said there's supposed to be an option for sending iMessages as text messages. He said you're supposed to tap and hold the iMessage and a menu should pop up with the option to send as text message. The menu did pop up but there was no such option.

What's wrong with my phone? Why won't turning off iMessages automatically switch conversation to text messages and why does the option to send as text message not show up in the options menu?
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,497
Points
48
Location
Arizona
If I go into Settings->Messages and turn off iMessage, then all my texts are now green, indicating SMS message (regular text). The send button is also green showing that these will not go out as iMessage. This works today and worked a couple years ago when I was traveling to places where I didn't have data.

Try that setting and see if that works.

The menu to select text or iMessage that you describe does not exist (iOS 13.2) so I wouldn't look for it. Let me know what option you are using to turn off iMessage.
 
Top