Tracks get out of order when I re-rip.

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

robcharlus

New member
Joined
Mar 27, 2004
Messages
145
Points
0
Age
67
Location
Vienna, Virginia
Please choose the appropriate forum for this topic. Thank you. My problem is that I have had to re-rip certain tracks to iTunes. iTunes puts the re-ripped tracks at the end of songs for the CD instead of where they belong. I've checked the tagging information, and that accurately states the track number. But it still ends up out of place.

A longer explanation of the problem: I ripped all my CDs to my computer before I got my iPod. Mostly I used musicmatch, but have since switched to iTunes, deleting musicmatch from my computer. I got an iPod, and it quickly loaded about 20 GB of tracks. In playing back the tracks, I found that about 5% or so had distortion. Although I initally thought it was the iPod, a playback of the music on the computer showed that the tracks there had the same flaws. I deleted the defective tracks on the computer and the iPod. I then re-ripped the defective tracks, and everything seemed fine -- no more distortion on the tracks. But when I began to play the CDs back on the iPod, I noticed that the tracks were out of order. The re-ripped tracks would always be at the end of the CD regardless of where they were originally. I checked the tagging information, and it was correct. For example, if I replaced track 4 of 12, it would still be identified as 4 of 12. But it would also listed as the last track in the iTunes library, and on the iPod. The only alternative I have found is to re-rip the entire CD.

Is it possible to replace only one track and have it be in the right place in track order?
 

AndyH

New member
Joined
Feb 17, 2004
Messages
4,868
Points
0
Location
Philly 'burbs
It almost sounds like you have your iTunes Library sorted by "Date Added" column, instead of by Artist or Album. Look in iTunes for the column heading that has the arrow icon in it, this is the column that your Library or Playlist is sorted by. Setting the sort to Artist or Album will place the songs in the correct order (assuming your tags are correct).
 

robcharlus

New member
Joined
Mar 27, 2004
Messages
145
Points
0
Age
67
Location
Vienna, Virginia
I don't think I have the tracks sorted by date added. First, I checked the edit/view options, and I don't have this category checked. Second, I have no column for it in the library, as I wouldn't given that I don't have this box checked. Third, iTunes will put the re-ripped track with right artist and album (I generally have the library organized one way or the other). It just is bumped to the end of the track list.

Based on another thread, I tried adding a track number column. that shows that the track has the right number in its tag (something I had previously confirmed). But the library always shows track 4 following track 12. In other words, the tracks are listed as 1, 2,3,5, etc. to 12, 4.

Obviously this isn't a fatal flaw -- I can re-rip the entire CD to fix the problem. But I would prefer not to, and don't understand why, with the information in the tag, iTunes doesn't insert track 4 between 3 and 5.
 

dordale

New member
Joined
Aug 3, 2003
Messages
871
Points
0
Location
Sacramento, CA
robcharles--
Another possibility...maybe iTunes is writing the tags for album or artist a little bit differently than musicmatch did. Try highlighting all the tags in the album, right click and choose get info. Then re-enter the Album and Artist info and click on "OK". After this, will the tracks sort correctly?

Hope this helps!

dordale :)
 

robcharlus

New member
Joined
Mar 27, 2004
Messages
145
Points
0
Age
67
Location
Vienna, Virginia
Dordale -- you're brilliant. yes, that works.

I'm regretting having used musicmatch to rip the CDs in the first place. If it has the error correction feature, it's not clear. I've noticed no problem with the re-ripped tracks on iTunes.
 
Top