One Song File is not recognized by iTunes

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

rupertmundy

New member
Joined
Jul 20, 2014
Messages
2
Points
0
I have a perplexing problem regarding just one of my music files not being recognized by iTunes. I like to make my own albums of artists and in this case I want to add the Beatles' Don't Let Me Down to the Let It Be album, but after making the necessary changes, i.e. changing the album title from the Past Masters album to the Let It Be one, etc., it does not go into the Let It Be Album (it does show up in the list of songs with Let It Be as the album but when you click on either Artists-The Beatles-Let It Be or Album-Let It Be, the song is not listed) I've done this before with other songs and albums with no problems. What happens in this case is when I try adding the Don't Let Down file, it creates a new Beatles directory and a new but separate Let It Be album with just the new song in the album. The file plays through so its not corrupted. How can I get iTunes to put the Don't Let Down file into the established Let It Be album? Thank you in advance for any insights and help. :)
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,885
Points
48
Location
Arizona
My guess is that the one song is marked as Part of Compilation and the rest of the album is not or vice versa.

Get Info, Advanced settings should show the value, and it needs to be the same for the song and the album.

If that does not work, you may need to check the Spelling of the Album or Artist on all the songs. There could be a trailing space.

You may also need to look at Sort Album and Sort Artist. Make sure they are the same as well.
 

rupertmundy

New member
Joined
Jul 20, 2014
Messages
2
Points
0
Thank you for the quick response! It turns out I had my settings to manually manage my library and when I let itunes do it, everything was read okay and the files were in the alternate albums I created. Thank you again for your response.

Rick
 
Top