My Mac is not recognizing my iphone…or it won’t work..

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

DR0570

Member
Joined
Nov 11, 2018
Messages
286
Points
18
it keeps saying “This iphone is open in another window” but it’s NOT! because it’s not recog in the finder.
8493
So WHY is this happening??
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
10,061
Points
63
Location
Arizona
The first thing I do on my iPhone is turn OFF Personal Hotspot, to prevent the computer from using my iPhone's data connection when I am syncing. Apple should add a switch to disable USB usage of the personal hotspot so I don't have to do this step.

Apple has help on not being able to find the device in Finder: https://support.apple.com/en-us/HT204095 which is of course updating and rebooting everything. They seem to forget about the preferences, so see that next.

You may need to set the preferences of Finder to show USB devices (Apple seems to assume these preferences are set on by default).
  1. Plug your iPhone or iPad into your Mac.
  2. Click Finder in the Menu bar.
  3. Click Preferences.
8494

Show iPhone in Finder showing how to click Finder, then click "Preferences" (Image credit: iMore)
  1. Click the Sidebar tab.
  2. Click the checkbox next to CDs, DVDs, and iOS Devices to check it if the box is empty. If the box is already checked, still click it to uncheck it and wait a few seconds.
8495

Show iPhone in Finder showing how to click the Sidebar tab, then click the CDs, DVDs, and iOS Devices checkbox (Image credit: iMore)
  1. Click the checkbox next to CDs, DVDs, and iOS Devices again to check it off and wait a few minutes.
8496

Show iPhone in Finder showing how to click the checkbox for CDs, DVDs, and iOS Devices again to check it (Image credit: iMore)
After a few minutes, your iPhone or iPad should appear in the sidebar of the Finder under Locations.

That should fix your initial problem.

They also have general help on using Finder to see your device: https://support.apple.com/en-us/HT210611 it will be in the left column.

This is a new computer, and even if you moved the iTunes Library from the old computer, it still recognizes this is not the same hardware it had trusted before.

Then you need to establish Trust.
From Apple Support: https://support.apple.com/en-us/HT202778
  1. Connect your iPhone, iPad, or iPod touch to your computer or another device.
  2. Enter your passcode, if you have one, to unlock your iPhone, iPad, or iPod touch.
  3. If you want to allow your computer to access information on your device, select your device in Finder and click Trust, or if you're using iTunes, click Continue.
  4. On your iPhone, iPad, or iPod touch, confirm that you allow your computer or other device to access your data. If you don't want to trust the computer or other connected device, tap Don't Trust on your device. If you want to trust your computer, tap Trust.
That should be all you need to get the sync started.
 

DR0570

Member
Joined
Nov 11, 2018
Messages
286
Points
18
Yes, i did ALL that. it’s still giving me the same message. i had to take it out and put it back in again several times before it worked. and now it’s doing it again… 🤷😡🤷
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
10,061
Points
63
Location
Arizona
I think Apple has broken the Trust system, and you may have to Trust the computer and enter your passcode every time the phone is connected.

Be sure to disable the HotSpot on the phone before connecting it, as that may add another Trust prompt and make it slow for the phone to show up in Finder.
 

DR0570

Member
Joined
Nov 11, 2018
Messages
286
Points
18
it’s doing it again! i enter the phone and computer passcode. it still says it’s open in another window… i even tried rebooting my mac. this time it wont stop doing this…
 

DR0570

Member
Joined
Nov 11, 2018
Messages
286
Points
18
ok… sorry after staying in there for about 5 minutes it came on…🤷
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
10,061
Points
63
Location
Arizona
Settings->Personal Hotspot, turn off Allow Others to Join
 
Top