iTunes 7.3: Ignoring symbols in browser (sorting) is not always a good idea.

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

S2_Mac

New member
Joined
Oct 24, 2006
Messages
4,878
Points
0
Location
About 3 feet in front of the monitor
If you adjust the "Sort Order" fields for some, but not all of your tracks from a given album, iTunes will actually create two entries in your album listing (in the browser) for that one album
Just FYI -- I see that same behavior in iTunes 7.2/Mac.

Not all bugs are new ;-)
 

rockmyplimsoul

Active member
Joined
Jan 3, 2006
Messages
5,492
Points
36
Location
In the Pub
Website
www.last.fm
iTunes 7.3.2 released today ... still has the wacky sorting for numbers and symbols. However, two things seem to be improvements:

(a) Fixed the "Apply Sort Field" utility which replicates the Sort data of a song to all other songs of the same artist, album, etc. That worked in 7.3 but was broken in 7.3.1. This fix is especially important for the workaround needed to put numbers & symbols at the top of the library.

(b) Not only does the "Apply Sort Field" utility work again, it now allows you to clear out the Sort fields on multiple items. For example, if you remove the Sort Artist info on one song, you can now use "Apply Sort Field/Same Artist" to empty that field on all other songs by that artist. Previously this utility did not work with "null" data.
 

tokerblue

New member
Joined
Feb 11, 2007
Messages
39
Points
0
I guess I'll wait for 7.4 and hope someone comes to their senses about the sorting...
 

mustbeburt

New member
Joined
Oct 11, 2006
Messages
2
Points
0
Age
40
Location
rochester, ny
it also now ignores the "a" in a band name like it does the "the".

for example The Get Up Kids has always been filed under "g" because iTunes ignores the "the".

however, it now puts A Perfect Circle under "p" because it ignores the "a". their name is not Perfect Circle... it's A Perfect Circle. they should be filed uner "a", not "p" !!!

:mad:
 

mc_razza

New member
Joined
Feb 18, 2007
Messages
13
Points
0
Location
Tasmania, Australia
Okay, I have a related issue so I thought here would be the perfect place to post it. I'm sorry if this has already been posted. If it has could someone please direct me to the proper thread? Cheers. :)

Whenever I listen to music on my iPod I go Music>Artists>"artist X">"Album/Single Y". The albums/singles are sorted first by alphabet and then by numbers/symbols eg: if I click on Music>Artist>AIR and the albums/singles would be listed as (from top to bottom) Moon Safari, Pocket Symphony, Talkie Walkie, Virgin Suicides, 10,000Hz Legend. BUT HERE'S THE PROBLEM. I use my iPod as a storage device eg: I save my university assignments and other related stuff on my iPod so that I can work on them at home and at uni (p.s. iTunes automatically opens whenever I conect my iPod to their mac computers, I thus close iTunes because I have no need to have iTunes open when I'm at uni)). Whenever I connect my iPod to any Mac computer at uni, work on an assignment and then disconnect it and then turn on my iPod again and play music, the albums are sorted differently. Instead of alphabetically then numerically it is sorted numerically THEN alphabetically so for my example would now look like: 10,000Hz Legend, Moon Safari, Pocket Symphony, Talkie Walkie, Virgin Suicides. So when I come back home and auto sync my iPod with my computer iTunes has to rearrange all the numbered albums/artists back to what they originally were BEFORE I connected my iPod with a Mac computer at uni. This REALLY, REALY, REALLY ####s me. How do I get around this? I don't want the university's mac computer to automatically rearrange my iPod's music library. I want to keep the way my library is originally arranged. Please help. :)

Helpful info:

My iTunes: 7.4.1
iPod: 5G video 30GB, the "Open iTunes when this iPod is connected", "Sync only checked songs and videos" & "Enable disk use" boxes are checked under the iPod summary tab.
I have a PC running Windows XP

Univeristy's Mac computers iTunes version: 7.0.2 I think (certainly of the iTunes 7 series for sure)

I hope you guys can help me. I'm sorry if I'm not too clear with my explanation, too, so bear with me. :D

Cheers,
mc_razza
 
Last edited:

rockmyplimsoul

Active member
Joined
Jan 3, 2006
Messages
5,492
Points
36
Location
In the Pub
Website
www.last.fm
Have you tried un-checking the "Open iTunes when this iPod is connected" option? That would prevent iTunes from booting when you connect your iPod, and might prevent things from getting re-arranged.
 

Mase3

New member
Joined
Dec 17, 2007
Messages
1
Points
0
yeah this option sucks, but a way around it if you can deal with it is...


search the Artist such as "50 Cent"
right click a track name and select GET INFO
go to the SORT tab and put an "A" in the Sort Artist field
click OK
CTR+A to highlight all "50 Cent" tracks
right click and select ((Apply Sort Field)) > ((Same Artist)
click OK and it should be on the top of your library/iPod list

it gets a lil tricky with the more and more #'s you add, but a new version will be out soon
 
Top