Ipod NOT showing all songs for Artist!

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

lildudejds

mmmhmmm
Joined
Oct 31, 2004
Messages
190
Points
0
Age
30
Location
St. Louis Missouri
ok when i click on an artist...it wont show all the songs i have for it...it only shows like 1 or 2....

this isnt for all artists..but some of them it is....and i know that my songs are on there, cuz when i go to "all songs" they are in there...


help please!
 

pinkcamel

New member
Joined
Feb 1, 2005
Messages
89
Points
0
are they ogg or wma files?

........ make sure theyre either m4a or mp3 files
 

lildudejds

mmmhmmm
Joined
Oct 31, 2004
Messages
190
Points
0
Age
30
Location
St. Louis Missouri
they are the right files...i had no problems with them on my 3g...
and like i said..theya re on the ipod...they just dont appear when i go to artists
 

DORF18

New member
Joined
Aug 7, 2005
Messages
33
Points
0
Age
31
ok this is an odd problem that happened to me too and i have found no solution and it is the worst part about the 5G. make sure all of your files have album names in them. if only some of them do the ones that dont will not show up when you hit all in the artist selection. its very very odd... for instance i have White blood Cells by the White stripes, but i also have the song Blue Orchid that isnt on that album, so i didnt even put the album into the tag... but it wont show up in that menu, but if you go to the songs menu you can find it... it just takes forever...
 

lildudejds

mmmhmmm
Joined
Oct 31, 2004
Messages
190
Points
0
Age
30
Location
St. Louis Missouri
the dorf...yeah im glad u know my problem...i fixed it(kinda) by either making all the songs have album titles..or none of them...that makes them all appear

thx
 

Riddell

New member
Joined
Jun 27, 2005
Messages
38
Points
0
Age
31
Location
Australia
Wow i was just about to start this same thread because i have the exact same problem and its really annoying me. Its really odd that they made the 5G like this because if i remember correctly on the 4G it would show all of the songs.

As you said it only happens on artists with one album and the rest not filled in. That is, if you have an artist with 5 songs and 2 of them are from the same album and the other 3 you havent filled in, when you click on artist it immediately jumps to that album and shows only 2 songs. However if another song is from a different album, ie. two albums from the same artist, when you click on the artist it shows the 2 albums you can choose or you can pick 'All' which shows all the songs from the artist. It should just say 'All' for every artist.

Does anyone know ways around this, apart from either deleting all my albums or filling them all in because with some of my songs i dont know what album they are from.

Please help
 

n2xe

Audio Evangelist
Joined
Dec 19, 2005
Messages
484
Points
0
Location
New York
Website
www.n2xe.com
Just uncheck "Part of Compilation" in the info tab (right click on song in iTunes click "get info" hit "info" tab) and your stuff will show up under Artist. (re-sync of course...)
 
Last edited:

tccpg288

New member
Joined
Jan 2, 2006
Messages
4
Points
0
Age
32
My problem is similar, except I'll have the exact same artist in 2 separate categories. For instance, one will say Elton John and then a few of his songs will display when I click it, and then right under that will be another Elton John category. I don't understand this at all.
 

davie

New member
Joined
Dec 7, 2005
Messages
14
Points
0
Location
Melbourne, Australia
n2xe said:
Just uncheck "Part of Compilation" in the info tab (right click on song in iTunes click "get info" hit "info" tab) and your stuff will show up under Artist. (re-sync of course...)
Tried this, doesn't make a difference.
 

davie

New member
Joined
Dec 7, 2005
Messages
14
Points
0
Location
Melbourne, Australia
Here's a tempoary fix that I found about a week or so ago on Ask iLounge 11-10-05, for those who don't know.
And now, for this week's Ask iLounge column:

Q: I just got the new fifth generation iPod and love it, but I noticed a weird software issue. When I go to listen to an artist and have songs with an album name and then ones with no album name, the ones with no album name do not show up in artists. If I navigate using “Songs,” the missing songs are definitely there. Do you know why this happens? Can I change this behavior back to the fourth generation style?

- Erik

A: We’ve noticed this too, and we too are a bit annoyed by it.

Here is the precise behavior we’ve observed:

For any artist with for whom there is only one album, the fifth generation iPod skips the intermediate “Album” screen used by previous iPods, going straight to the track listing. Cool!

However, for any artist that has one non-empty album tag that also has tracks with empty album tags, the tracks with empty tags are indeed omitted from this quick menu. In our opinion, such a case should yield the intermediate “Album” menu with the single album and the “All” option, as it does on previous iPods.

Note that if the artist has songs with empty tags and two or more unique, non-empty album tags, the “Albums” menu appears as normal, complete with the “All” option.

It seems as though Apple was attempting to simplify the navigation process for those artists for whom you only have one album, but in doing so they’ve neglected to count an “empty” album title as a trigger for the extra menu. We’re pretty confident that this is a bug introduced by a rushed “feature,” and that it will be fixed soon. However, only Apple knows what will get fixed, and when.

Here’s a work-around that one could easily implement (and easily remove, should the bug get fixed):

Give all of your album-less tracks a placeholder album title. To do so in the easiest way possible, begin by creating a new smart playlist that collects all songs for which “Album” “is” “(empty)”. Next, select this playlist in the source column, choose “Select All” from iTunes’ “Edit” menu, and choose “Get Info” from the “File” menu.

Now, change the Album field to something other than (empty)... like perhaps the text “Empty”, or something more discreet like a simple dash character ("-"). This will trigger the iPod’s intermediate menu, where both the “All” option and the “Empty” album will be available.

Granted, this is clearly not the best way to operate, but it is a solution that will allow you to access all of an artist’s songs from the “Artist” menu.

Want to reverse this change? Simply change your smart playlist so that it collects songs whose “Album” “is” “Empty” (or “-”, or whatever you chose). Then use the Get Info window to once again empty the album titles.
 
Top