iPod classic 7th Gen crashing when browsing playlists

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

bubbascant

New member
Joined
Sep 10, 2015
Messages
12
Points
0
This has been an on-going problem and I'd sure like to see if someone out there can figure it out. Here's what I know:

1. I am still using 10.7 itunes because it is my preference. I have 12 on another computer to hook up iphone 7 which won't work with 10.7.

2. I have several iPods. I have four of them that are 7th gen of one kind or another. I have figured out I think that some have 2.0.4 and the latest has 2.0.5. I think that 2.0.5 is what is causing the issue but I could be wrong.

When I hook my 7th gen to XP machine with itunes 11, I don't experience crashing of the 2.0.5 iPods. If I use my W7 10.7 itunes and sync and then go to use it, and browse the playlists, when I select a playlist, the iPod crashes and reboots.

I've been in the forum a couple of years ago trying to figure it out. I've investigated bad song files as possibilities but that's not it. There were a number of things suggested to try but none work. I've tried different USB to iPod cords (have lost track of which model had which cords as I have so many of these - including 5th and 6th Gen. BTW, NONE of those crash or have any issues so obviously this is a software issue.

Is there a way to back the 2.0.5 back to 2.0.4 or is the hardware on the mobo incompatible with the 2.0.4 firmware?

This is massively aggravating as I've paid good money for these iPods. Why do they keep crashing with 2.0.5? If I hook up, sync and then use a couple different iPod 2.0.4 7th gen iPods they don't crash. Why? Now, that said, they did crash at first after syncing, but I took off anything such as audio books etc., and whatever I did seemed to help. My settings are:

Sync only checked songs
Enable disc
I only sync selected playlists
I include music videos (and I've tried using with and without having videos on the iPod)

If I hooked this same iPod up to 12 itunes on XP, it will back up and not crash. However, I can't keep copying music and playlists back and forth. Is this an W7 issue? 10.7? I have past versions of itunes such as 10.6. I think 10.7 was where they removed the coverflow but I could be wrong.

Some suggestion mentioned gapless playback, but that's not it. None of this is corrupt song files or anything such as this. If so, why would 5th and 6th gen iPods work fine - in W7 and 10.7? And the 2.0.4 7th gen seem to work better. I've updated and they're not crashing so I'm about ready to sell these 2.0.5 ones and just look for 2.0.4.

ANY help would be enthusiastically received. Thanks!
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,424
Points
38
Location
Arizona
I remember your other thread so I won't repeat the Restore advice.

Have you considered disabling Disk Mode? You really don't need that unless you are using this as a thumb drive too.
 

bubbascant

New member
Joined
Sep 10, 2015
Messages
12
Points
0
Thanks for the reply. I tried with and without enable disc but it didn't matter. I will try again but curious to know what difference that would make?
I'm really thinking its something to do with iTunes version and the 2.0.5 on the iPod but I've not figured how the relationship between that might works. Just very mystified as to why 7th gen with 2.0.4 with iTunes 10.7 works fine but not the same on 2.0.5.
I'm not sure if, or how, I can put 2.0.4 to replace the 2.0.5. I read that it would be a hardware incompatibility.
Thanks so much.
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,424
Points
38
Location
Arizona
Disk mode could have some interaction, where the OS is trying to use the drive for 2 purposes vs. 1. It is unfortunate that this didn't help.

There is no iTunes version difference with syncing with classics that I am aware of, and it is your choice not to upgrade to a working iTunes.

We discussed downgrading in the last thread and came to the conclusion you don't have the files necessary for that transition.
 

bubbascant

New member
Joined
Sep 10, 2015
Messages
12
Points
0
I actually do have all sorts of backup itunes libraries and itunes .exe versions going back to version 4 or 5.

I do have a piece of good news. Based on your input, I tried restore one more time. I noticed during redoing that it was putting some audio book on even though I only put one playlist on at first. I have no idea why it did as I had no audio book as part of a playlist or the audio book tab. I went to the audio book I noticed it tried to put on when I did just one playlist and unchecked it and synced again. So I did one playlist, synced, ejected and then checked. No crash. I then put another bunch of playlists and did the same thing. No crash. Then put on more, checked. No crash. Finally have all my playlists back on, though I didn't add any video files. So far, all works great. No crashing. So thank you for putting it out there to try again. Not sure why it didn't fix before when I restored. Thank you again. all sorts of backup itunes libraries and itunes .exe versions going back to version 4 or 5.
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,424
Points
38
Location
Arizona
Who knows why the one file caused such a problem. Maybe it is bad.

You can download old iTunes versions, but that won't help your iPod FW version. You would need the 2.0.4 FW file and the signature file to go with it. Most people don't have these.

Glad you got it sorted out.
 
Top