iPhone 3g - Mail app not working??

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

sMg 3G

New member
Joined
Jul 13, 2008
Messages
4
Points
0
Location
UK
hey,

I was lucky enough to get my hands on an 8gb 3g iphone on friday there, so far so good...apart from mail. The white background of the app loads for a few seconds and then closes. Ive tried playing with the settings alot, but no luck:confused:

can any one help??
 

Funk-O-Meter

New member
Joined
Jan 14, 2006
Messages
57
Points
0
Age
43
I've got the same problem. I had this problem on the last firmware (1.1.4) after I jailbroke it and I was able to fix it by SSH'ing into it and changing the permissions on the mail folder. But now with the new 2.0 firmware I can't SSH into it because the client side app for doing that isn't installed on the phone anymore. At least that's what I'm assuming. So until they drop the jailbreak program for 2.0 I'm stuck without mail. Well I can check it through safari as it's a Gmail account but the mail app is broken.

Any Ideas? Is that why I can't SSH into it?
 

happyjoe

New member
Joined
Jul 15, 2008
Messages
2
Points
0
fix?

hey i live in canada and i was having the same problem. i called rogers and they told me to erase all content and settings and start from scratch. you can do this through Settings > General > Reset. the only problem is it takes 2 hours. i havent finished it yet, its about half way done, but i will tell you if it does get fixed.
 

sMg 3G

New member
Joined
Jul 13, 2008
Messages
4
Points
0
Location
UK
well i tried what he said, and so far so good...mail is working...just restoring my backup.

ill post when the restores finished..
 

Surf Monkey

New member
Joined
May 13, 2003
Messages
3,566
Points
0
Age
55
Location
The City of Roses
Website
www.dvdinmypants.com
Good to hear. Did you do the two button reset on the iPhone first to see if that worked? Sometimes that can "unstick" applications that aren't working. Hold down the Home and Lock buttons until the "slide to turn off" prompt appears, then restart iPhone. Just a tip in case it happens again. The two button reset, when it works, is a better option than restoring your whole handset.
 

sMg 3G

New member
Joined
Jul 13, 2008
Messages
4
Points
0
Location
UK
yeah I had already tried the two button reset...

but iphones fully restored with mail working :D
 

happyjoe

New member
Joined
Jul 15, 2008
Messages
2
Points
0
good to hear!

rogers actually did something right. it worked for me also. too bad it takes2 hours. good luck guys
 

pokka

New member
Joined
Nov 2, 2005
Messages
21
Points
0
If you are restoring your settings from a non-jailbroken phone - or if you are not restoring at all - then you just need to reboot the phone first, and if that doesn't work, restore it.

If you are restoring from a jailbroken phone and it doesn't work, that's because you improperly set the permissions on the phone last time you fixed the problem in 1.1.3 or 1.1.4.

You probably followed some instructions that told you to chmod 755 or 777 on some files, when in fact the correct procedure would have been to chown them to mobile.mobile

So if you still have your old iPhone around, install SSH and SSH into the phone (username root, password alpine). Then type

cd /var/mobile/Library/Mail
chown mobile.mobile *
cd /var/private/Library/Mail
chown mobile.mobile *

Then connect the phone back to iTunes, rename it to something unique, and force it to make a backup (in Windows, you right click on the phone icon to do so).

Finally, connect the 3G iPhone and restore it as a backup (the name it suggests as the backup should be the unique name you chose above - if not, nuke your backup folder in iTunes and make a backup of the old iPhone again and repeat).
 

Funk-O-Meter

New member
Joined
Jan 14, 2006
Messages
57
Points
0
Age
43
Yea, last time it was a jailbroken 1.1.4 and I was recommended to change permissions on the mail folder to 777which worked like a champ. So your saying now that those folders are still set like that but inside the 2.0 software? And of course now I can't ssh into it. Well I'm about to sell the thing for a new phone anyway, what do I need to do to "virginize" it?
 
Top