Individual settings under "Fetch New Data" not working

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

daihard

New member
Joined
Oct 25, 2006
Messages
795
Points
0
Location
Lynnwood, WA
[NOTE: I posted the same question in the Apple Support Discussions forum.]

Hi.

I'm having problems getting the individual push/fetch/manual settings to work. Here's the scenario.

I have three mail accounts set up on my iPhone 3G. They are "MobileMe," "GMail" and "Work."

I go to "Settings" -> "Fetch New Data" and turn "Push" OFF. I then go to "Advanced" at the bottom and set "MobileMe (Mail)" to PUSH. I thought this would enable PUSH on my MobileMe account while keeping it disabled on the other accounts.

However, my iPhone still won't get new mail automatically.

What am I doing wrong?
 
Joined
Nov 15, 2004
Messages
13,238
Points
36
Age
50
Location
Toronto, Canada
Website
www.ilounge.com
No, you have to have "Push" turned on globally for it to work on any account.

The non-MobileMe accounts simply don't support push AT ALL, so you won't be able to turn push on for them individually anyway. If you go to the "Advanced" tab, you will see that there is no "Push" option for any of the accounts except for your MobileMe account.

Under the main Settings, Fetch New Data screen, ensure that you have a fetch time set to something other than "manual" for your non-MobileMe accounts. If you have a specific account that you do not want to auto-fetch, you can set this to "Manual" individually under the Advanced tab.

In other words, your settings should be as follows:

Under Settings, Fetch New Data:

Push: ON
Fetch: Every 15 Minutes, Every 30 Minutes OR Hourly

Under Settings, Fetch New Data, Advanced:

MobileMe: Push
GMail: Fetch or Manual
Work: Fetch or Manual

Accounts set to "Fetch" will use the timing set on the previous screen. Accounts set to "Manual" will not automatically retrieve e-mail at all - you'll have to visit them and check for mail manually.
 
Last edited:

daihard

New member
Joined
Oct 25, 2006
Messages
795
Points
0
Location
Lynnwood, WA
jhollington said:
No, you have to have "Push" turned on globally for it to work on any account.

The non-MobileMe accounts simply don't support push AT ALL, so you won't be able to turn push on for them individually anyway. If you go to the "Advanced" tab, you will see that there is no "Push" option for any of the accounts except for your MobileMe account.
Hi Jesse.

I tried that as well. The problem is, when Push is globally ON, then even the accounts where push is individually turned off will get new mail pushed from the respective servers. FYI, both my Work (Exchange) and Yahoo! accounts have a "Push" option. It is only my GMail account that has no "Push" option available.

Any further thoughts?
 
Joined
Nov 15, 2004
Messages
13,238
Points
36
Age
50
Location
Toronto, Canada
Website
www.ilounge.com
Well, yes you're correct that Yahoo and Exchange will still get mail pushed unless you specifically set those under "Advanced" to either "Fetch" or "Manual" This works to disable any kind of push for those accounts in my case, although of course if they're set to "Fetch" they'll still POLL for new e-mail based on your fetch interval setting.

Note that you may need to reset your phone or at least terminate the Mail app and restart it (go into Mail app and hold down the home button for about 8 seconds) after changing these settings for them to take effect right away.
 

daihard

New member
Joined
Oct 25, 2006
Messages
795
Points
0
Location
Lynnwood, WA
jhollington said:
Note that you may need to reset your phone or at least terminate the Mail app and restart it (go into Mail app and hold down the home button for about 8 seconds) after changing these settings for them to take effect right away.
Thanks; that did the trick. I had to terminate the Mail app in order for the new individual settings to take effect. :cool:
 
Top