Email - notification of new emails

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
I have all my email accounts set up on iPhone 7+, but deliberately choose not to get new emails pushed through. When I need to view emails on phone, I will do that manually. About once a week, the phone seems to go off and check and tells me I have a number of unread emails. Is there another setting somewhere I need to turn off?
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
Yes. Settings->Passwords and Accounts->Fetch New Data, Turn off Push and check Manually.

That will get new email when you open the email app or refresh the Inbox.
 

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
Yep, That is how I have the phone set-up so there must be some other form of electro-trickery going on....
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
Did you also tap on each email account and move the check mark from Push to Fetch (this will use the upper level settings) or Manual (you have to open each account and refresh the inbox to see new messages)
 

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
Yes, have done that. The strange thing is this isn't happening daily. I don't think it relates to syncing but I can't rule that out either yet.
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
Do you kill the mail app after you are done using it?

If not, it is running in the background, and that may count as manual checking for mail when the phone wakes up from sleep, or you accidentally bring it to the foreground, etc.
 

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
I am fairly ruthless at killing Apps when not in use. I have a work related App that really chews the battery so I check a couple of times a day that no Apps are running in background
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
Assuming you have all the accounts set to Fetch and the Fetch set to manual and Push disabled, then you should only get new email IF you open the Mail app.

How are you connecting to these accounts? Exchange? Pop? IMAP?
 

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
Errrrr, not sure !
BUT, I now know what the catalyst is. Syncing with iTunes on the PC, and a number of unread emails popped up. I can't see a setting withing iTunes that would stop that from happening but at least I know what is causing it. Thanks for your help
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
That is interesting. Does the computer you sync with also run outlook that accesses the same accounts? Is iTunes configured to use test outlook to sync contacts send more? Disabling that link in iTunes to outlook could stop the update of email to the iPhone.

To be more clear:
Do you have iTunes syncing with Outlook and this device? (Connect device to iTunes, click on Info, see if you are syncing email, contacts, or calendars)
Do you have iCloud syncing with Outlook? (iCloud options, is Mail, Contacts and Calendars selected?)
 
Last edited:

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
I do use the same PC to sync OUTLOOK with the phone - it is syncing Contacts and Calendar (and bookmarks) I can see no option to select email. Screen dump attached.8179
iCloud is syncing with OUTLOOK as well
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
That is why the iTunes sync updates the mail on the phone. If you don't mind that then leave it on.

In your phone, Settings->Passwords & Accounts->iCloud, you can disable email sync with iCloud by turning it off here. Then you should be on manual mail only for your Phone.

By not changing the settings for iCloud on your computer the email is still synced with iCloud, and all devices that are using the same Apple ID can still access that mail. If you disable Mail sync in your computer iCloud settings, that will make email only be on your computer, and not shared to any other devices including your phone.

Hopefully that makes sense.
 

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
Ummmmm. to confuse matters a little, haven't synced the phone for a few days and just noticed I have notification on phone of a few unread emails . Weird Plus
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
If your phone is still syncing to iCloud for Mail, then you will get those notifications.
 

Kim F

Member
Joined
Jul 7, 2008
Messages
36
Points
6
Location
Canberra, AUS
The plot thickens. Once the phone decides to show me I have a number of unread emails, after syncing or not syncing - that number does not change despite whether emails are read via other technology - PC or ipad. 3 days ago it told me I had 2 unread emails which was true at that time - I have synced twice since then, received tons of emails, read them, deleted most but the phone still shows 2 unread. Not bothered but there is something strange going on in background - once !
 

cjmnews

Moderator
Staff member
Moderator
Joined
Apr 26, 2006
Messages
9,347
Points
38
Location
Arizona
Of course it won't. If you don't allow updates, then the iPhone doesn't know any of that occurred. You have to choose between being up to date or limited updates.
 
Top