Do I Really Need iTunes 10.7 to sync iPhone

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

GinoLicious

Member
Joined
Feb 15, 2005
Messages
651
Points
16
Age
32
Hey Guys,

So this troubling matter has arisen today and I cannot seem to solve it. My iPhone will no longer sync to iTunes because it says my iTunes is too old and I need to upgrade it.

I run a Macbook. With leopard on it(10.5).

When I go to update iTunes via apple site, it says I cannot because I need snow leopard (10.6).

So is this really happening to me? I need a newer OS to upgrade my iTunes so I can put new songs on my iPhone that I have purchased?

If there is no way to over ride this, I'm phoning apple and demanding a free upgrade copy of 10.6. To not be able to sync your iPhone because you cannot upgrade iTunes is despicable.
 

kornchild2002

New member
Joined
Feb 21, 2004
Messages
12,203
Points
0
Location
Cincinnati
Welcome to the real world. Apple did the same thing to people with Windows 2000 a while ago and they are just now doing it to people running Leopard (which is 5 years old!). Spend the $20 and upgrade to Snow Leopard as Apple definitely isn't going to give you a free upgrade. They didn't give people running Windows 2000 an upgrade to Windows XP and they aren't going to help out Windows XP users when they stop supporting it soon.

There isn't anything you can do other than upgrading your OS in order to upgrade iTunes. It is normal and part of the tech world.
 

GinoLicious

Member
Joined
Feb 15, 2005
Messages
651
Points
16
Age
32
But that is windows.... I would think they would be a little bit more loyal to their actual customers. Geez, I guess I do have to upgrade. After being an apple consumer for 8 years, i am disgusted with that move.
 

Savannah

New member
Joined
Mar 20, 2009
Messages
54
Points
0
We're talking about the richest company in the known universe, do you think they got into that position by being nice to people?!
 
Top