Busted 5G screen

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

funkyg

Member
Joined
Jun 21, 2006
Messages
61
Points
6
OK, I thought that the 1.2.3 firmware update had corrupted my screen but I've gone back to 1.2.1 and it's exactly the same.
Update the iPod last Thrusday, went home with it plugged into my Drive+Play. Took it out of the car when I got home. Drove to work in the morning and left it in car, connected to the Drive+Play. The temprature according to my car display was a coupl eof degrees above freezing. When I went out at lunch time I noticed that the screen had a line across it. Picture below.



Strange thing is, this line is only visible when the backlight is lit. If the light is off the line disappears. Now here is the really strange thing. If the iPod is on for a length of time, say about an hour, the line seems to shrink and fade a little.
I have done a restore, made no difference. Rolled back the firmware, made no difference.
I can get a replacement screen from ebay for just £15 abd I've seen the video on how to fix it, definitely within my skills.
Before I waste my money does this look like a fault with the actual screen or general hardware fault? I know it's probably the cold that has broken the LCD, but I just wanted a second opinion.

Cheers.
 

joker0153

New member
Joined
Oct 7, 2007
Messages
223
Points
0
Try to play videos on it, maybe graphic intensive videos. it may be stuck pixels.


or download a color pattern video. like the ones you see on TV when there is nothing broadcasting.
 

justblaize

New member
Joined
Feb 20, 2004
Messages
451
Points
0
I'd say there's something wrong with the screen. Changing the LCD on the 5th gen iPods is pretty darn easy.
 
Top