Beginners Guide. Copying an Audio CD to a Bookmarking iPod File. All iTunes process.

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

rawdata

New member
Joined
Mar 7, 2005
Messages
2
Points
0
Location
Raleigh, NC
But how do you actually bookmark a file?

Ok, I've done everything in these posts, but can't get my iPod to remember where I was when I go away from that book and come back again. How do you actually tell the iPod to bookmark that location in the book you're listening too? This is a highly useful feature to me since some of the books in a single file that I have are over 20 hours long and if you try to fast forward using the diamond progress bar, you can only go a little over two hours before the iPod gets lost and you have to start from the beginning.

Like others, I listen to my books as well as other music. When I go back to the books, I'd rather not have to revert to the "post it pad stuck to the back of the iPod with the time written on it" method of bookmarking... :)

Thanks!
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Re: But how do you actually bookmark a file?

rawdata said:
... How do you actually tell the iPod to bookmark that location in the book you're listening too? ...
Thanks!
First, look at file in iTunes Library, and determine if the "File Kind" is "Protected AAC audio file". If so, highlight and right click on the file name, choose Show File, and look to see that the file has an *.m4b extension. If either one of the answers is no, you did something incorrectly in the step by step. Most likely you still have an m4a file. Go back to the renaming steps. Actually, if it is m4a, all you have to do is select rename on the left side of the Show Song file window, key in the b, enter, double click on the renamed files -- which will insert the renamed file in iTunes, and R click clear the m4a indexed names from library, drag to iPod.

Are you apple or pc?

Suggest you consider MarkAble for PC (link below next to EZGuide), which will manage the whole process for you.

Just reread your post. 20 hours long likely exceeds the maximum length the iPod will accomodate. If greater than 320 mb, you need to reduce file size. The max file size may be even less. Some think in the 120 MB range.

Good luck.

Robert
 
Last edited:

rawdata

New member
Joined
Mar 7, 2005
Messages
2
Points
0
Location
Raleigh, NC
Thanks for the tips. The file is protected AAC, .m4b, and 288M at 24kbps and 16kHz. Also ripped in Stereo mode. It is a conversion from .mp3, but everything went smoothly in the transition. I should also note that I've done 4-5 of these and they just don't seem to work for me. Some are also smaller files, ripped at different speeds, though still over the 120M range and under the 320M limit.

I'm using OS X and a 40G iPod.

Thanks again for your help!
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
OS X? Mac?

You are using the Doug Adams Applescripts?

I have no exprience with mac but have tried to make the guides mac friendly, but that is not easily done. Maybe someone with Mac experience will weigh in. Try looking at and posting in this thread:

http://forums.ipodlounge.com/showthread.php?s=&threadid=68629

It may be the file sizes are too large. Some think 120 is the max file size that will operate satisfactorily on iPod.


I would like to include in the guides a link to mp3 merge for mac freeware if you have one, please.
 

lole34

New member
Joined
Feb 22, 2005
Messages
97
Points
0
Age
34
Location
montana
I did everything on the instructions untill the renaming the file. I don't know what you mean, what file am I renameing? I have never done anything with files on a computer and this is all verry overwhelimg. I can't get my itune to realize that my audio books are audiobooks and when I snyc with my ipod the go in the album catagory. Bookmarking dose not work for me eather. I don't know why this is not working for me or what I am doing wrong I am just verry fustrated. Also when I imported my first cd it has 99 "songs" all of about 45 sec but when I join tracks it will only do it to number 83 please help.
 

Podunk

New member
Joined
May 11, 2003
Messages
847
Points
0
Lole, I'm gonna suggest that you do what I do. In the future, just get your audioobooks from Audible.com

They are already in a format for the iPod and you won't have to worry about all this nonsense.

You just download, snyc and listen, and the file wll automaticallly be int the Audiobooks Menu on your iPod.

You can even get your first two books free by clicking by signing up at Audible.com
 

Suze

New member
Joined
Apr 25, 2005
Messages
1
Points
0
Thanks so much for the instructions. :) Everything worked out great. EXCEPT, I just don't get this part at all-

B. Rename the files, remove the song names that no longer have a file associated with it from iTunes, and add the renamed files to iTunes song list

Please, would someone explain this.

Thanks so much,
Suze
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Suze,

Look at the appropriate guide listed in signature below for precise instructions on how to do what you ask. Probably Guide 3 or 4, depending on the original source of your files.

Better yet, try MarkAble, also linked in sig below for beginner friendly do it all for you. It will rename and remove files so that you don't have to figure out how to do it with the guides. Free trial and $15 if you want to continue to use it.
 

ns_tulkas

New member
Joined
Apr 28, 2005
Messages
2
Points
0
This is a good tutorial. The only problem I'm having is even though the files are labled .m4b, they still do not show up under the auidiobook category in my ipod.

The tracks were originally .mp3 files downloaded from the internet. I have deleted all the files with the .mp3 and .m4a extensions, and made sure the files in iTunes are the ones with the .m4b extensions I had converted. I then tried deleting them from iTunes and reinserting them, then re-syncing with the ipod, but still no luck.

I don't understand why this won't work?

[Mac OS X Panther, 4G 20GB iPod]
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
what file type shows for these files in iTunes under the "kind" column? If not showing as Kind = AAC file, then you did not convert properly. Go to Edit/preferences/Importing tab and change to import as AAC files. See guide for more details.

Uh, oh, I see mac now. You will have to use the apple script conversion. See the guide and
http://forums.ipodlounge.com/showthread.php?s=&threadid=68629
 

ns_tulkas

New member
Joined
Apr 28, 2005
Messages
2
Points
0
I already installed the applescript and ran it, and it did nothing. It didn't change the situation, I mean.

I'm at a loss.
 

bdkorn

New member
Joined
May 7, 2005
Messages
1
Points
0
I have an 8 hr MP3 that I am attempting to convert using the MarkAble tool. It completes successfully however the resulting file is only ~ 2 hrs long. (it worked fine on a 20+ hour one)
The original file was encoded at 48kbps and is 176 mb.
I have set the ITunes import setting from 24 - 48 but none of these setting has corrected the issue.
The original MP3 plays fine on my ipod and in itunes.

Thanks for any assistance,

Brian
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Check to be sure that your original file is actually 8 hours. 176 mb at 48 kbps sounds like substantially less than 8. I am away from my main computer (until Monday) at which I could check a couple of file lengths to confirm this.
 

hawkwood

New member
Joined
Jul 6, 2005
Messages
3
Points
0
Location
Arlington, MA
I have the same problems. I very carefully followed all the steps, my book files are now all mb4 stereo. I see them transferred to my iPod, but when I go to "Audiobooks' it's empty!

HELP!

(Mac OS 10.39, iTunes 4.9, 3G iPod 15GB)
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
you must do the applescripts for mac to change the tags to get into audiobooks, to bookmark and to skip in main menu shuffle.

That is about the extent of my understanding of the mac process. Look at the links to applescripts, especially morionds post on the subject.
 

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
hawkwood said:
I have the same problems. I very carefully followed all the steps, my book files are now all mb4 stereo. I see them transferred to my iPod, but when I go to "Audiobooks' it's empty!

HELP!

(Mac OS 10.39, iTunes 4.9, 3G iPod 15GB)
Welcome to the iPodlounge forums. Since the main step in creating a bookmarkable file that will show up in the Audiobooks section of your 3G iPod involves running the MakeBookmarkable AppleScript on an m4a file, can you check your file under iTunes by highlighting it, typing CMD-i (Mac keyboard shortcut for File -> Get Info from the iTunes menu bar) and looking at what Kind of file shows up on the Summary Page? It should show Kind: Protected AAC audio file after running the MakeBookmarkable AppleScript, and read Kind: AAC audio file before you run the AppleScript. If files do not show up as Protected AAC audio files under iTunes they won't appear in the Audiobooks section on the iPod or be bookmarkable.

If the file does not show up as Kind: AAC audio file, I would do a quick check of trying to run the MakeBookmarkable AppleScript on a small m4a file (for example, a music track you imported), to see whether Kind changes from AAC audio file to Protected AAC audio file upon running the AppleScript. If this works, you should be able to get a bookmarkable file that shows up in the Audiobooks category onto your iPod. (Note that on a Mac you should not have to rename files to get bookmarking working).

If neither your homemade audiobook file nor your small test file show up as Kind: Protected AAC audio file after running the MakeBookmarkable AppleScript, the next thing to try is repairing file permissions. The AppleScript attempts to change the file type information reported to the system (and this will show up as a change in the keywords of your iTunes Music Library.xml file, although you won't see it; no changes get made to your actual audiobook or test music file), but it may not have permission to do so, even though you have Administrator privilege through your account. This can happen when other software you've installed on your machine has modified file permissions, with indirect consequences for your ability to run this AppleScript.


Disk Utility, which resides in the Utilies folder of your Applications directory can be used to repair permissions, but since it cannot repair any open file, the cleanest way to repair permissions is to run this from your install CD (CD1 of two). Insert the CD, then restart your machine fromthe pull-down menu below the Apple icon on the menu bar. Hold down the 'c' key as your machine boots up until you can hear the CD drive engage (10 or 15 seconds), indicating a boot from the CD instead of the hard drive. When the Installer comes up select Installer -> Disk Utility from the Apple menu bar. Under Disk Utility, select your boot volume (Macintosh HD), then select the First Aid tab. Select the Repair Permissions option at the lower left. The utility will report any permissions repairs it makes as it scans your files. It should complete with a message that permissions have been repaired. After Repair Permissions completes, quit the Disk Utility. You'll be returned to the Installer. Quit the Installer and when prompted, select Restart. [Note: it is a good idea to repair your permissions this way before and after installing new software and/or system upgrades].Now try running the Make BookMarkable AppleScript again.

The likely problem points in getting bookmarkable audiobooks onto your iPod are: problems merging files or associated with resetting file types (the easiest thing to do is to join tracks by CD - you don't have to remember to reset import file formats to the correct type [aac vs mp3] or keep track of intermediate file products before you merge, but many people want a single file for their audiobook]), problems with permissions in running the MakeBookmarkable AppleScript (for Mac users), problems updating files to the iPod (you may have earlier versions of the file on your iPod, and the new versions may not have been transferred -- this is most likely to occur with autosynchronization, which is one reason some Mac users were confused about the need to rename files [with autosync the newly bookmarkable file doesn't look "different", so it isn't automatically updated]; manual or semi-automatic sync'ing makes this more obvious).Final comment: on a 3G iPod you can encode your audiobooks as mono, without fear of lockups, but it's a good idea to use stereo (as you do), so that these files will also work without problems on later model iPods.

Hope this helps. Let us know what happens.
 

hawkwood

New member
Joined
Jul 6, 2005
Messages
3
Points
0
Location
Arlington, MA
THANK YOU, THANK YOU! IT WORKS!

The files were not Protected AAC audio files. I installed "MakeBookmarkable", and they were changed correctly. However, they wouldn't copy onto my iPod because the "unprotected" files were still there. So I made a Smart Playlist that would contain anything with "My Book" in the comment section, and made that a playlist to be automatically updated.

Now my book shows up under Audiobooks!

Where the "unprotected" files replaced? They've never shown up in the iTunes window when i click on the iPod. But I saw them transferred once and I worry about them taking up my limited space.

But thank you again!
 

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
hawkwood said:
The files were not Protected AAC audio files. I installed "MakeBookmarkable", and they were changed correctly. However, they wouldn't copy onto my iPod because the "unprotected" files were still there. So I made a Smart Playlist that would contain anything with "My Book" in the comment section, and made that a playlist to be automatically updated.

Now my book shows up under Audiobooks!

Where the "unprotected" files replaced? They've never shown up in the iTunes window when i click on the iPod. But I saw them transferred once and I worry about them taking up my limited space.
Great that things worked! If you added a comment you should have updated your iPod's library database with the information that this is a bookmarkable audiobook file. This didn't require "replacing" the files themselves -- just changing the database information associated with these files on your iPod.

How to get the iPod to update bookmarkable status in autosync mode

This is only an issue if you use automatic updating and have previously sync'd your iPod to versions of your audiobook files that were not bookmarkable. iTunes only updates information about files on your iPod when it detects changes in that file -- edited or added keywords, different file length, etc -- compared to the version in your iTunes Library. Adding a comment like "My Book" forced your iPod to re-read your Mac's iTunes Music Library.xml file and add the information that this is a bookmarkable file. Without a similar action the file would not have appeared in the Audiobooks category on your iPod, and it would not have been bookmarkable.

With manual updating it's more obvious what's going on, since you can delete the old (nonbookmarkable) versions of audiobook files from your iPod and add versions that were made bookmarkable by running the AppleScript, and expect these files to show up in the Audiobooks category and bookmark properly on your iPod.

Similarly, there's no problem using autosync with audiobook files made bookmarkable before you connect your iPod. When these files transfer over the first time, they will be flagged as bookmarkable files. You do not need to add comments or put these into smart playlists (unless you find this convenient for other reasons) to make these show up as Audiobooks and bookmark on your iPod.

Managing Audiobook Updating and Space on Your iPod

hawkwood said:
Where the "unprotected" files replaced? They've never shown up in the iTunes window when i click on the iPod. But I saw them transferred once and I worry about them taking up my limited space. [/B]
There are a number of ways to modify your updating preferences if you're worried about limited space on your iPod. With manual updating only files that you designate will be transferred to your iPod. This allows you to keep a much larger library of audiobooks and music in your iTunes Library than you can hold on your iPod. This is also a good option for people who access (different) iTunes libraries on more than one computer, since the contents and playlists on your iPod don't have to mirror what's on your computer. The main drawback is that your ratings and playcounts don't get updated automatically, unless your entries are in smart playlists or, for Macs I think Doug Adams has written an AppleScript you can run to update these entries when you connect your iPod.

If you want to continue to use autosync, consider changing your preferences to check Only update checked songs. Take a look at the posting linked above (and a second one linked from that one), and read the iPod 201 tutorial on different synching options. To keep your iPod from updating when you connect in order to change your preferences hold down the CMD + Option keys on a Mac (Shift + CTRL on a PC) as described in how to stop they ipod from auto-syncing when connected to iTunes FAQ entry. Take a look through the tutorial and decide what is most suitable for you.
 

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
mashgap said:
are there anyway you can make chapters if you use windows?
Not yet. ChapterTool is only a command-line tool beta for Mac so far, but they are planning to support Windows.
 
Top