Iphone 8+ won't connect to home WiFi !


New member
Last week my phones WiFi was working perfectly fine with no problems. Three days ago out of nowhere my phone no longer would connect to my apartments WiFi, when I tap the WiFi connection it just says "no internet connection". I live in a college apartment type of thing ( not normal on-campus dorms ) so I don't have access to the router that provides my WiFi. I originally thought that it was just the internet provider but my phone connects to other WiFi connections, but just not this one, no other devices in the apartments are having trouble connecting including my roommates iPhones/laptops. I've tried just about everything I could within my capabilities; restarted my phone, reset my network settings, reconnected to the WiFi, left airplane mode on for a while, and made sure my ios was updated but nothing is given me any luck. Sometimes the WiFi will randomly work for about 10 minutes a couple times a day but that's about it. I called the internet service provider but they basically told me to run through things that I had already tried. I still have hopes that maybe within the next week it'll just fix itself, but it's really stressing me out because I can enjoy doing normal things on my phone without using data and experiencing super slow connection. Any ideas?

p.s I have 0 knowledge about underlying technical stuff so please simplify any explanation thank you!


Staff member
Can other devices keep a connection to this WiFi?

It sounds like a WiFi problem, specifically where 2 devices are being given the same IP address.
You could use manual settings to change the IP address of your device, but you may accidentally grab the IP of someone else.

In Settings->WiFi-><home Wifi> jot down or memorize the IP address, Subnet Mask and Router you have
Tap on Configure IPv4
Tap on Manual
In the IP address section (assuming the Subnet Mask is try entering in the same IP address as before except the last set of digits after the dot/period there try setting the value to a high number like 254.
In the Subnet Mask set the same value as you saw before
In the Router set the same value as you saw before
Tap Save in the top right corner.

Hopefully that will get you on the network. If it fails, try a different number going down from 254 until it works.
I had to do this in a condo I was renting and it got me access most of the time.


New member
Whoever has control of the router needs to reboot it. Who do you pay rent to? They should help you!

Sent from my iPhone using Tapatalk