HELP Audiobooks not showing up

GO TO ADMIN PANEL > ADD-ONS AND INSTALL VERTIFORO SIDEBAR TO SEE FORUMS AND SIDEBAR

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
I added six audiobooks from CDs yesterday. I merged the files, converted them to AAC, changed the extensions to .m4b. Each book is in 5-10 sections depending on the length of the book. They are all in the same directory. For some reason, only three of the files are showing up in my ipod under the Audiobook section. Any ideas?

Thanks.
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Q.Some or all of renamed AAC files don't show in Audiobooks. Edited Summary/Solution

(PC oriented)

CD conversions show in iPod main menu audiobook category only if AAC and renamed m4b (or AAC with tags altered by applescript for mac) EDIT; and if deleted from and re added to iTunes Library after renaming m4b. MP3 files will never show in iPod Audiobook category even if made bookmarking. First check that files show as protected AAC Audio File under the Kind column. If Kind column doesn't show, R click any column heading and check Kind. If you R click any one of the files>show file, you should see a window that looks like this. All should have m4b extensions and when you hover cursor on them, should show protected. (NOTE: Only AAC files with renamed file extension of m4b and iTunes Music store and audible.com audiobook downloads show in Audiobooks main menu category of iPod, play faster, and skip in main menu shuffle. In the Kind column of iTunes the AAC/m4b files show as "Protected AAC audio file" when, in fact, they are not protected.)

Caution: Do not convert and rename files with iPod attached to computer.

Summary of The Problem:
Some files were renamed while auto synch iPod attached to computer. A few files got to iPod after renaming (the ones in Audiobook) and some files got auto added to iPod before renamed (The ones not in Audiobook). Even though successfully converted to AAC/bookmarking, iTunes did not recognize a change sufficient to update with auto synch with newly renamed file. All the files bookmarked, but some did not show in iPod Audiobook Main Menu category.

Edit: I Deleted al the posts in this thread that did not contribute to solution.

CAUTION: Do not rename with an automatically update songs and playlists iPod attached to computer.

Solution
What Ivy figured, with a little help, how to fix (Remove offending files from iPod with temporary change to manual synch, change back to auto synch) and then iPod will auto resynch, adding renamed files):

1. Change from autosynch to manual
-attach iPod to computer
-Edit>Preferences>iPod tab>Music Tab, you will see
this window
-Change check to Manually Manage Songs and Playlists.
-Click OK
2. Highlight iPod and find the songs/books that are not showing up in audiobook
- Highlight>R click>Choose clear (Removes the non-audiobook files from iPod)
- Repeat for each file/song/book section
3. Return to Edit>Preferences>iPod tab>Music Tab, you will again see this window
- Change check to Automatically update all songs and playlists.
- Click OK. This then will cause an auto synch to add the renamed files to your iPod
4. Pat yourself on the back. Should be fixed.
=============================================

Possibly will work -- easier, but I haven't tested:

With iPod attached, file by file, R click>Get Info>Summary tab. Should show as AAC Protected File. The act of checking may change it to that and cause enough change in files to cause the next auto synch to change the file on iPod so that it shows in Audiobooks.

or, also possibly

Force all the files to show File Kind by, while in Library of iTunes, R click on any column heading and click on Kind to cause it to have a check. Look to be sure all files are Protected AAC. Then resynch.

If anyone gets the possible works to work, please let me know so I can change the guides. I do not auto synch.

=============================================
Another, but more complicated way (my original suggestion):

If auto synch (automatically update all songs and playlists) your ipod:

1. With iPod attached, go to iTunes Edit>Preferences>iPod tab>Music Tab, and check "Only update Checked songs." This is the same window where, if you are automatically synching, "Automatically update all songs and playlists" is checked.

2. Safely Remove iPod from computer.

2. In library uncheck all the files that do not show in Audiobooks. That is, go to the song entry in Library and click on the little square next to book/song name. Or, highlight all the songs, R Click, and choose "Uncheck all selections."

3. Connect iPod to computer. That should remove all the songs that are not in audiobooks -- the ones you unchecked

4. Remove iPod, making sure to use safely remove hardware

5. Go back and check all the songs/books

6. Reattach iPod and allow it to synch

7. You have now removed and replaced all the iPod files with the renamed files and they should show in Audiobooks.


If manual synch, further things to look at :

Find all the files look at the file extension to be sure you got them all changed to m4b. You may have an intermediate-step file in your directory instead of having renamed a few to m4b.

in iTunes, R click, choose show file, and look at them carefully to be sure they are all m4b.

in iTunes, be certain each is showing as AAC Proctected under kind column.

if that doesn't work, look closely at the guide to CD's linked below and see if you skipped a step.

MarkAble may not take care of this problem. it all for you without much chance for error. like this
 
Last edited:

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
Hmm still not working

Robert - thanks for your reply. Everything appears to be correct. I have 39 files. They are all in the same directory. They are all .m4b. They are all AAC protected, yet only three of them show up in my audiobooks. The rest are showing up as songs. I might try to re-convert them all to AAC and move forward from there. I'll let you know if that works.
 

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
Nope, that didn't do it. I can't imagine why three are working and the rest aren't.
 

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
Robert - I did join tracks. I uploaded all six Harry Potter books (actually I already have all six of the US books, these are the UK versions). I too am perplexed, but I can't spend too much more time trying to figure it out. At least they are on my ipod.
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Does your Show file look like this?

Your files should look like this after highlight one of the files>R click>choose Show File, and in window that opens, click at top of window on View>then check List and Details. (Ignore the sitx file)
 

Attachments

Last edited:

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
Re: Hmm still not working

Ivy said:
Everything appears to be correct. I have 39 files. They are all in the same directory. They are all .m4b. They are all AAC protected, yet only three of them show up in my audiobooks. The rest are showing up as songs.
Before trying any new conversions, check that all these Audiobook files appeared as "AAC protected" under iTunes on your computer before syncing your iPod or before manually transferring the files to your iPod. I think this problem of only some audiobook files appearing in the audiobooks category on the iPod really surfaced in iTunes 6, with the support of the 5G Video iPods. In some instances, simply doing a Get Info (keyboard shortcut: ctrl + i for PCs; cmd + i for Macs) on these files after they are placed in the iTunes Music Library database and clicking on "Next" forces iTunes to read the tag contents and update the status of the file as an "audiobook".

If you autosync, you'll also have to change some entry or add a new file to your library to get the "updated" database to "take"; for example, edit one of the audiobook files and add a comment -- anything, even a "."-- or change some field. Try this after you've clicked through the files that didn't transfer to the Audiobook section correctly. Just start with Get Info on the first file and keep hitting "next". Then try syncing your iPod again. See if this helps.

P.S. I think the reason for the problem is that the way we're using this unsupported feature of iTunes is having iTunes "reclassify" these files as though it were a regular audiobook purchased from iTunes. It does this by cross-checking entry fields in the music header and file name. When the files are first imported, they have a different status. When you do the renaming of the extension, you're making iTunes reclassify the file, but it has to do so by seeing the inconsistency in the headers you have. With the 5G Video files, and extra checks needed to keep iTunes compatible in both Mac and Windows versions, I think it no longer necessarily completes all these checks immediately for all files. Just my guess, but it seems to work this way.
 

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
robert,

The reason that people are finding this so confusing is that some of the files transfer correctly, but not others. Furthermore, when they go back to check whether these show up as Protected Audio Files, the act of checking makes iTunes (on the computer) read the headers and classify these as Protected Audio Files -- even if they were not Protected Audio Files in the database at the time the files were transferred to the iPod. (The Schroedinger's cat dilemma.)
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
moriond said:
robert,

The reason that people are finding this so confusing is that some of the files transfer correctly, but not others. Furthermore, when they go back to check whether these show up as Protected Audio Files, the act of checking makes iTunes (on the computer) read the headers and classify these as Protected Audio Files -- even if they were not Protected Audio Files in the database at the time the files were transferred to the iPod. (The Schroedinger's cat dilemma.)
Moriond,

Does this mean that a simple check (show file, what? and where? iTunes or iPod) make the files show up in audiobook category? Would the files have been bookmarking without showing up in audiobook? I need to make a note in the guides and FAQ. This can drive even the most advanced user batty.

I had to look up your Schroedinger's cat reference and having just finished "Siddhartha" (Free AAC/m4b download at Learn out Loud for a short time) this morning, had a jolt of deja vu. You are showing your background, in a positive way, of course. :D

I have GOT to go do my taxes. This is sooo much more fun and a way to procrastinate!
 
Last edited:

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
Arrghh

After I figure out all the "ipodese" you guys are saying, I will try everything you are advising me to do. I am new at this.

My files looks like this (I hope I'm attaching this correctly)

Thanks so much for your help. I'm sure we'll figure this out.
 

Attachments

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
Robert,

Here's the link to the post summarizing what was happening with only some converted episodes showing up under the Audiobooks menu along with another post describing the starting point of someone[/url] who had this problem.

This exchange is slightly confusing, because the second link starts up with the description of the problem and what the user tried, and that post started in the middle of a thread simply labeled "Help" that appeared under the Books and Spoken Word forum. Keep reading the second link thread, then jump to the first link (which is at the end of a post in the Mac forums) for the resolution. I put a summary description of what was going on in the preface of my post there.

What I was trying to say in the earlier posts, is that if users (either on a PC a Mac platform -- doesn't matter which) convert audiobooks from .m4a to .m4b, and are using iTunes 6, they need to make sure that iTunes' database considers the newly imported and renamed entries to be "Protected Audio Files" before transferring these over to the iPod. The simple act of checking the file status should make this happen -- or anything that forces iTunes to read the file headers and update the status. I don't think this is necessary in any of the older versions of iTunes, because the cross-checks were less complicated. This is why some posts advising you to actually start playing the files first will work -- you don't need to actually play them, but you probably do need to make sure that iTunes at least loads in the headers and reads them.

Probably another way around this would be to actually add the converted (renamed files) to the library as new entries with File -> Add to Library and then deleting the old entries, but that seems even more tortuous on the Windows side. This problem wouldn't exist if you created the .m4b files out side of iTunes and were adding them to the Library for the first time, because then there would be no original status information to supercede.

I'm not using iTunes 6 myself, but the behavior (and the fact that following this recommendation of making iTunes read the header first seems to work) is consistent with this explanation. It also explains why this is showing up in iTunes 6 and not in the earlier iTunes versions (or at least, only very sporadically in the earlier iTunes versions).

Hope this helps.
 

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
Oh yeah, I should let you know that the bookmarking is working, even thought they are not showing up as audiobooks.
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Ivy, Pretty good for a novice. I only figured out in the last month how to post a screen shot and I wrote the guide in May '04.

Looks like you have all the files converted properly, and if I interpret Moriond's comments correctly, they got synched to your
iPod before you renamed them and your iPod/iTunes doesn't know to up date them. If I have interpreted Moriond correctly, you need to force iTunes to update them.

Since you seem to be on line now, tell me if you are manually synching or auto synch and we can take it from there.

This is very new to me also, but I think we can figure it out.

Robert
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
Ivy,

Anticipating an auto synch:

1. With iPod attached, go to iTunes Edit>Preferences>iPod tab and check do not synch unchecked songs (or something similar to that wording). Disconnect iPod safely.

2. In library uncheck all the files that do not show in Audiobooks. That is, go to the song entry in Library and click on the little square next to book/song name

3. connect iPod. That should remove all the songs that are not in audiobooks

4. Remove iPod, making sure to use safely remove hardware

5. Go back and check all the songs/books

6. Reattach iPod and allow it to synch

7. Hopefully that works. Let me know. I will be here awhile doing a couple of complicated emails.

Robert
 

moriond

New member
Joined
Oct 14, 2004
Messages
721
Points
0
Ivy,

What I was saying is that your conversions seem perfectly fine, and I believe that if you were doing exactly the same things under an earlier version of iTunes, all your audiobooks would show up under the Audiobooks category under your iPod, and be bookmarkable, etc.

The way that iTunes decides which files are audiobooks (as opposed to music) depends on how those entries are identified in its database -- specifically, in the iTunes Music Library.xml file. These entries are created when new tracks are added to iTunes (on the basis of what is in the headers and tags). When you ripped your CD, and entry was created, it was tagged under the general category of a music aac file and not an audiobook. When you play a file, iTunes consults its music database (iTunes Music Library.xml) file for what kind of behavior to expect. This is much faster than trying to read the file each time and decide how long it is, what kind of decoder should be used [aac, mp3, lossless, wav, etc.] to play the file. If there is any inconsistency between the properties listed in the iTunes Music Library.xml database file and the header information or file name of the file, then the database will get updated (if you are using iTunes on your computer). This kind of updating is not an option on the iPod player. That is why the FAQ for troubleshooting audiobook conversions asks you to check to see whether iTunes lists this as Kind: Protected AAC Audio file on your computer, because if it doesn't show this on your computer, it certainly won't play as an audiobook on your iPod.

The new wrinkle may be that under iTunes 6, with the support of a multitude of additional new file formats, iTunes may no longer complete its inconsistency check for all the audio files and notice that even though you entered the audiobook as a general AAC file, you changed its extension (without explicitly creating a new entry in the iTunes Music Library.xml database that flags this as an audiobook). Whereas in earlier iTunes versions the database would have had time to catch the inconsistency and automatically update the entry as an audiobook, now it no longer has time to work through the list of consistency checks and catch all your entries. Remember, we're using a trick that changes the status midway. We were relying on one of Tunes' failsafe mechanisms to track a change that we never explicity gave to the database, and we're using an unsupported feature. This would explain why some (but not all) of your entries may register under the Audiobooks menu.

What's different now, is that when you go to check on whether the summary page shows Kind: Protected AAC Audio File, the act of checking makes the new status come up this way -- it wasn't reset to Protected before you forced iTunes to read the file headers and do t he check, and consequently, it wasn't flagged that way in the database file when you transferred the files to the iPod; it is reset to Protected now that you've looked at it. The other way to see this is to turn on the display of Kind in your iTunes View options (I think the keyboard shortcut is ctrl +j on a PC; it's cmd +j on a Mac) and see whether the Kind is set to Protected after you've converted to .m4b. If it isn't, do a File -> Get Info and see whether the status changes. Do this before you transfer the files to your iPod.

Sorry for the core dump. Someone who has iTunes 6 running can test this. Hope this helps.
 

robert

Moderator
Moderator
Joined
Oct 30, 2003
Messages
1,375
Points
0
Location
Atlanta
ok
you are auto synched and need to check Only Update checked songs. I just didn't have my iPod attached so couldn't see that window. That is step 1.

I need to read Morionds post more closely to see if what I suggested will work. In the meantime you can try that if you want, it will not hurt and may force the issue. There seems to be a simpler way, but I need to re-read Moriond's post.
 

Ivy

New member
Joined
Dec 28, 2005
Messages
34
Points
0
Moriond - if I deleted the files from my ipod, then put them back on, will that fix the problem?
 
Top