Can't restore purchases


funkyg

New member
I have recently updated my iPad Air (original) to a 2018 iPad 9.7.

My iPad Air was previously jailbroken which meant that one of my banking apps wouldn't install, so I setup the new iPad as a new device rather than setting up from a backup.

I was able to install all my apps/games bar one - "Where's my Perry?", as it seems to have been removed from the App Store. Not a problem as I had the file saved in my library from when apps were installed through iTunes as well as direct from the App Store.
Installed it and it is working but I am unable to restore the purchases for the additional levels.

I have two different AppleID's (long story), and I know this can cause problems. I'm pretty sure I bought this app with my main account and this is what I am logged into the iPad with. When I try to click restore purchases it gives the error "Regrant failed".
I have tried logging out of my main account in settings/and logged into the other one and this gives the same error.

I have the app installed on my iPhone as well and if I click the restore purchase button on there it all goes through.

Any ideas on getting the extra levels or am I stuck with only playing them on my phone?
Cheers!
 

cjmnews

Moderator
Staff member
Moderator
Good job getting the app installed in the current iTunes environment.

My guess is that the unlock requires a response from a server that is no longer active. So you probably can't unlock it on the iPad directly.

Now it is possible that if you restore your new iPad from your iPhone backup you could get it. But that means starting over again.

The choice is yours, and it may not work, but I think it will.
 

Top