Artists showing in Song list, but not when syncing.


bunraku

New member
Just installed the latest version of ITunes and am wanting to sync to an Ipod Touch 7.
I've done this loads of times, but for some reason am having an issue today.


I don't have Albums, but a collection of songs(over 4000) so just call the Album my name.
When I look at the songs in my library they all have an Artist and Album Artist.
However when I go to sync with my Ipod, you can select sync all songs, artists, etc etc.
Artists don't show and I just have the 1 album full of songs and you can see the Artists in smaller writing under the song title.

Is it because I am selecting Album is a collection of mixed Artists or something that's causing this?

Thanks
 

cjmnews

Moderator
Staff member
Moderator
Did you by chance mark all these tracks as a Compilation? That could hide the Artists if you have this set.

Try turning off the Compilation flag (Select all tracks, right click one, choose Get Info, In the Details section uncheck Compilation, click OK) and resync to see if that resolves it.
 

Top