A Tip for Syncing With a Library Larger Than iPod

OK, many of you are probably in my boat. You've got a library larger than what will fit on your iPod.

I'm coming from the MC9 world, and there I would create a Master Smartlist, exclude a bunch of artists, albums or whatever and always manage that one list to the size of my iPod.

All my other smartlists started off w/the rule "Playlist=iPod Tunes" so I was always assured they only contained songs that were on my master playlist (nested smartlists, a feature I wish iTunes had).

Anyway, I started making a Smartlist similar to my master one in itunes and quickly ran into a problem: I couldn't add all my rules, the dialog box got too big so I couldn't click the OK button.

So, I read help and little and learned about the checkboxes next to each song. That's the ticket then. Shoot, I thought, I gotta check off each song? No, I should be able to highlight a bunch and hold the <shift> key down and uncheck all the highlighted one. Nope didn't work..but....<cntrl> does work (not windows standard, but whatever, I'll cut them some slack ;)).

So, here is a step by step of what I'm talking about:
  • Click the Browse button in the upper right-corner so the Panes are viewable at the top.
  • Select an Artist in the pane at the top that you want to exclude from the iPod.
  • Hold down the <cntrl> key and click the first checkbox--all the checkboxes for that artist will become unchecked.
  • Continue for each Artist that you want to exclude. You can if you wish, as an alternative, select an Album or Albums and deselect that way as well
  • When done excluding all the artists, click on File>New Smart Playlist
  • Uncheck the "Match Any of the Following Conditions" checkbox
  • Check the "Limit To" checkbox, set it to 100 GB, sort by Artist
You're done, now click on the iPod Options button in the lower right-hand corner and select this Playlist to sync w/the iPod (and any others

You can of course use the setting in the iPod options to only match checked songs, but I like creating the Smart Playlist because it allows me to easily see the size of the tunes I have checked. I've yet to find an easy "view" in iTunes other than this to see checked tunes.

Hope that makes sense, might help some people....

Last edited:


Long Time Podder
Perfect Adam!!

The prospect of having to check and uncheck each box was making me nauseous. This should work out perfectly!!

Thanks again!


Official Shortbus Driver
maybe I'm missing something, but your step 'Next, Make a Smartplaylist, the only rule on it should be Sync only checked song' -

do you mean the checkbox second from the bottom 'match only checked songs'? because if I uncheck the top 'rule match' checkbox I can't click 'OK', but I cant see a rule category that corresponds to what you are saying -

Oh, you've got to uncheck the very top checklist. Where it says to match all the rules. Then the OK button will become available.

Sorry--forgot to add that.


Official Shortbus Driver
strange - i thought that is what you meant, but when i uncheck that top checkbox (leaving only the 'match checked songs only' selected) the 'ok' button greys out. I can only get it to re-enable by checking that top checkbox. . .


New member
Thanks Adam, I was beating my head against the wall last night trying to find my master playlist going with the iPod.


Official Shortbus Driver
theChronic said:
strange - i thought that is what you meant, but when i uncheck that top checkbox (leaving only the 'match checked songs only' selected) the 'ok' button greys out. I can only get it to re-enable by checking that top checkbox. . .
Noone else has this problem with the 'OK' button greying out if you don't have the top checkbox selected?
hehe, theChronic, I'm super sorry. T'was late last night and I don't know what I was thinking.

You're absolutely right. You have to have something checked. I'm not at home now, so I don't know what I did, but I think I checked the "Limit" box and set it to a really high value (larger than my library) like 100GB.

Then the OK button is available.

The key, is when you look at your Library (the # of songs) should be the same as the # of songs on this playlist.



New member
<cntrl>-click -- What's that?

I was trying to follow you Adam but have no idea what you mean by <cntrl>-click .


Official Shortbus Driver
ohhhhhhhh hehehe thanks, I thought I was crazy ;)

to rcwoll - he means hold down the 'Ctrl' key and then click.

Hold down the <cntrl> key, and click the first checkbox. It will uncheck the songs for the entire Artist or Album you have selected.

***Edit** Yeah, that's what I mean

C'mon guys...it was late for me. I'll clean the whole darn thing up.


New member
a much simpler way...

a much simpler way of accomplishing the same goal (i.e., a live-updating, master smart playlist) is to:

-- make sure all your songs are checked (i, for one, see no case when you'd want to un-check any song, ever. if anyone can think of why they are there, i'd love to know)
-- create a new smartlist
-- uncheck "match the following condition"
-- check "limit to" and type in "100" then choose "GB" then choose selected by "artist"
-- make sure "live updating" is checked, as is the default

voila! :D
Crawford..those are exactly the steps I outlined (albeit, you've done it in a much more sussinct way ;)).

Oh, and why would you want to uncheck songs? The whole purpose of the post: because my library is about twice the size of my 15 giger. I gotta uncheck.



...from berlin
iam sorry , but i need to ask for an easy'er way...
sitting here in germany, and my schools english does not fit to the long tutorial ;)
the problem (so i hope) i understand - and share it to. my musiklibrary is to big for autosync with the ipod. but the solution doesnt make sense to me. please could anybody be so kind, and gimme an step-by-step-"how to" like:
1.create a smart playlist ....
3... ( the way cwofford startet his entry)
so that i finally got a way to plug the ipod in and its autosynking to the musik i like to hear. Thanx