iLounge Forums

iLounge Forums (http://forums.ilounge.com/)
-   iTunes + Related Mac/PC Applications (http://forums.ilounge.com/itunes-related-mac-pc-applications/)
-   -   Can't change info in iTunes (http://forums.ilounge.com/itunes-related-mac-pc-applications/78628-cant-change-info-itunes.html)

Miamifan1354 02-23-2005 05:01 PM

Can't change info in iTunes
 
ok, so I've had my Ipod for a while, and I want to move some of the songs around by chaging the album and stuff like that in info. The only problem is, I can't change some of the info. I right click the song, hit get info, and then when it comes up after I click the info tab, everything is gray and I can't edit it. I can change some of the newer stuff I put on the Ipod, but it's the older stuff that I need to format. Any clue how to change this, or what caused it?

Jesse Hollington 02-23-2005 05:15 PM

The usual cause of this problem is the underlying MP3 files being flagged read-only, which may have happened if they were copied from a data CD.

If you're using Windows, try right-clicking on the entry in iTunes and selecting "Show Song File" This should open an explorer window in the directory containing that file. You can then right-click on the file itself, choose "Properties" and see if the "Read-only" box is checked. If so, uncheck it and click OK.

mekkab 10-08-2009 08:59 AM

also dir permissions
 
Quote:

Originally Posted by jhollington (Post 457581)
The usual cause of this problem is the underlying MP3 files being flagged read-only, which may have happened if they were copied from a data CD.

If you're using Windows, try right-clicking on the entry in iTunes and selecting "Show Song File" This should open an explorer window in the directory containing that file. You can then right-click on the file itself, choose "Properties" and see if the "Read-only" box is checked. If so, uncheck it and click OK.

You also need to have write permissions in the directory that the files are in.

I "chmod -R 775"'d and everything worked fine after that.

tbennettflynn 10-09-2009 11:18 AM

How can I do that with mac?
 
Quote:

Originally Posted by jhollington (Post 457581)
The usual cause of this problem is the underlying MP3 files being flagged read-only, which may have happened if they were copied from a data CD.

If you're using Windows, try right-clicking on the entry in iTunes and selecting "Show Song File" This should open an explorer window in the directory containing that file. You can then right-click on the file itself, choose "Properties" and see if the "Read-only" box is checked. If so, uncheck it and click OK.

How do I change that on mac?

Sparkee 10-09-2009 04:43 PM

On a Mac right click the file in Finder using the same steps jhollington outlined for Windows to find them in Finder and choose Get Info. You should see the "Sharing and Permissions" options at the bottom. Depending on your set up you may need to click on the pad lock in the lower right corner to log in as Admin to make changes. You can also also choose Get Info on the folder containing all your bad music files, change the permissions then click the "gear" icon at the bottom and then click "Apply to enclosed items". Change the Privilege for "your username (Me)" to Read & Write.

greenmonky 04-20-2011 01:27 PM

Can't change get info on itunes Fixed for windows 7
 
I select properties of my wife's itunes folder and created new user called everyone and gave full rights now i can edit get info again. So for windows it is permissions issue.

bozojim17 07-29-2011 04:08 PM

Windows 7 (64 Bit)
iTunes 10.4 version/
80Gb Classic 5th GEN


This will NOT work for me.
"SHOW IN WINDOWS EXPLORER"

I changed hard drives,and had to re-install all the songs back onto the ipod, I saved to an external HDD. But when trying to edit the song info, they are all greyed out.

I opened up one random song, clicked on SHOW IN WINDOWS EXPLORER, tried to un-check the READ-ONLY attributes,then went back to EDIT INFO, and it was still GREYED OUT. Then I tried the same thing for the Main TUNAGE folder where all my music is in,mostly all MP3's. Did the same thing with it's properties> un-check Read-only>apply> OK, went back into itunes and it's STILL GREYED OUT.

cjmnews 07-30-2011 02:28 PM

It is possible that your folder structure is read only, so altering it would require unsetting the read only setting on the top level folder and everything underneath.

It could also be the ownership of the folders. If you had to reinstall or moved the folders from another computer your login may not own the folders. Right click the top level folder, choose properties, then security then Advanced, and Ownership. Take ownership if you do not.

The same issues may exist for your iTunes library file. Check the read-only and ownership of it as well.

FlyinSquiRReL 10-25-2011 12:02 AM

Go to Libaries>Itunes>Itunes Media>Music. Right click on entire music folder and go to PROPERTIES then uncheck Read-Only. You only unchecked one song file that is why you thought it didnt work with this it should allow you to edit any song in your Itunes Libary.

ffischer 02-17-2012 09:55 PM

Can't change info in iTunes
 
I went to Libaries>Itunes>Itunes Media>Music. Right clicked on entire music folder and went to PROPERTIES then uncheck Read-Only. for about a minute it went through the entire database and then the window closed. It all looked fine, except that it did not change anything to my songs. in "get info" everything stayed greyed out.

cjmnews 02-18-2012 12:26 PM

Try checking out the Advanced Properties of the Folders and see if the Ownership is assigned to your account or not.

A second item to check is to make sure the iTunes folder is not read only, that is where the library file is located and if that is read only, you can't make updates.

jvainstein 11-07-2012 05:05 PM

Finally a solution
 
After trying to change read-only attribute for the mp3 files, and changing permissions for the iTunes Media folder WITHOUT SUCCESS, I found the solution: Convert your MP3 to AAC format.
It's done easily with iTunes, but I think this is a DIRTY TACTIC from Apple. Maybe this is why it's the most valuable company in the world: because it plays dirty.

Cold Irons 11-08-2012 06:46 AM

Dunno....I've got over 20,000 mp3's in iTunes, all can be edited with Get Info within iTunes. May want to actually understand your computer & it's OS prior to bashing others. (Not to mention ruining your lossy music files by transcoding lossy-to-lossy).

elvisp2013 11-16-2012 03:36 PM

Easy fix for INFO grey out
 
1) In iTunes, Click on FILE, top left

2) Scroll down to Library

3) Click on 'Library - Organize Library'

4) Click on the box 'Consolidate Files'

Presto - you're done.

ccobbster 11-30-2012 12:10 AM

Still gray boxes
 
I've tried all the suggestions, including consolidating my library and still am left with gray boxes. Have repeatedly unset the main iTunes library folder from being Read Only but won't permanently change it, even though I'm prompted as the Administrator to enter that password (and enter it). I'm confugulated!
Am desperately in need of help, trying to set up separate libraries for my kids iPod touches! Thanks in advance.


All times are GMT -4. The time now is 12:30 PM.