Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.

Topic: A Tip for Syncing With a Library Larger Than iPod

Reply Thread Tools Topic Search
Old 10-17-2003, 12:24 AM
#1
 

 
Join Date: Aug 2002
Location: Napa, California
Posts: 7,686
A Tip for Syncing With a Library Larger Than iPod

OK, many of you are probably in my boat. You've got a library larger than what will fit on your iPod.

I'm coming from the MC9 world, and there I would create a Master Smartlist, exclude a bunch of artists, albums or whatever and always manage that one list to the size of my iPod.

All my other smartlists started off w/the rule "Playlist=iPod Tunes" so I was always assured they only contained songs that were on my master playlist (nested smartlists, a feature I wish iTunes had).

Anyway, I started making a Smartlist similar to my master one in itunes and quickly ran into a problem: I couldn't add all my rules, the dialog box got too big so I couldn't click the OK button.

So, I read help and little and learned about the checkboxes next to each song. That's the ticket then. Shoot, I thought, I gotta check off each song? No, I should be able to highlight a bunch and hold the <shift> key down and uncheck all the highlighted one. Nope didn't work..but....<cntrl> does work (not windows standard, but whatever, I'll cut them some slack ).

So, here is a step by step of what I'm talking about:
  • Click the Browse button in the upper right-corner so the Panes are viewable at the top.
  • Select an Artist in the pane at the top that you want to exclude from the iPod.
  • Hold down the <cntrl> key and click the first checkbox--all the checkboxes for that artist will become unchecked.
  • Continue for each Artist that you want to exclude. You can if you wish, as an alternative, select an Album or Albums and deselect that way as well
  • When done excluding all the artists, click on File>New Smart Playlist
  • Uncheck the "Match Any of the Following Conditions" checkbox
  • Check the "Limit To" checkbox, set it to 100 GB, sort by Artist
You're done, now click on the iPod Options button in the lower right-hand corner and select this Playlist to sync w/the iPod (and any others

You can of course use the setting in the iPod options to only match checked songs, but I like creating the Smart Playlist because it allows me to easily see the size of the tunes I have checked. I've yet to find an easy "view" in iTunes other than this to see checked tunes.

Hope that makes sense, might help some people....

Adam




Last edited by ashawley; 10-17-2003 at 07:56 PM.
ashawley is offline  
Reply With Quote

Join the iLounge Community and the ad above will disappear.

Old 10-17-2003, 12:32 AM
#2
 
Freshman Lounger
 
Join Date: Oct 2003
Location: Seattle, WA
Posts: 4

Thanks a bunch. Exactly what I needed.
Radiant is offline  
Reply With Quote
Old 10-17-2003, 01:20 AM
#3
 

 
Join Date: Aug 2002
Location: Napa, California
Posts: 7,686

Glad it worked out fer ya!



ashawley is offline  
Reply With Quote
Old 10-17-2003, 01:27 AM
#4
 
Long Time Podder
 
Join Date: Sep 2003
Location: Brooklyn, NY
Posts: 1,047

Perfect Adam!!

The prospect of having to check and uncheck each box was making me nauseous. This should work out perfectly!!

Thanks again!



2nd Gen 20 Gig, 3rd Gen 15 Gig*
2005 Update - Sold the 2nd Gen 20, "TAP'D" the 3rd Gen 15 and now have a 4th Gen 60 gig iPod Photo, 1 Gig Shuffle, 2 Gig Black Nano, and 60 gig iPod Video.
Win XP/Win2K Combo Setup*
iMac 17" G5 (2nd Rev)
iBook 12" G4
SpideyPod is offline  
Reply With Quote
Old 10-17-2003, 01:28 AM
#5
 

 
Join Date: Aug 2002
Location: Napa, California
Posts: 7,686

Think I'll Sticky this for now.....since you guys are seeming to find it useful..

Adam



ashawley is offline  
Reply With Quote
Old 10-17-2003, 02:03 AM
#6
 
Official Shortbus Driver
 
Join Date: Oct 2003
Location: BC
Posts: 82

maybe I'm missing something, but your step 'Next, Make a Smartplaylist, the only rule on it should be Sync only checked song' -

do you mean the checkbox second from the bottom 'match only checked songs'? because if I uncheck the top 'rule match' checkbox I can't click 'OK', but I cant see a rule category that corresponds to what you are saying -

TIA
theChronic is offline  
Reply With Quote
Old 10-17-2003, 02:08 AM
#7
 

 
Join Date: Aug 2002
Location: Napa, California
Posts: 7,686

Oh, you've got to uncheck the very top checklist. Where it says to match all the rules. Then the OK button will become available.

Sorry--forgot to add that.



ashawley is offline  
Reply With Quote
Old 10-17-2003, 02:37 AM
#8
 
Official Shortbus Driver
 
Join Date: Oct 2003
Location: BC
Posts: 82

strange - i thought that is what you meant, but when i uncheck that top checkbox (leaving only the 'match checked songs only' selected) the 'ok' button greys out. I can only get it to re-enable by checking that top checkbox. . .
theChronic is offline  
Reply With Quote
Old 10-17-2003, 09:08 AM
#9
 
Pro Lounger
 
Join Date: May 2003
Location: DFW, TX
Posts: 618

Thanks Adam, I was beating my head against the wall last night trying to find my master playlist going with the iPod.



ToddW is offline  
Reply With Quote
Old 10-17-2003, 11:39 AM
#10
 
Freshman Lounger
 
Join Date: Jun 2003
Location: Sweden
Posts: 10

Sounds really complicated - and I have no idea of what it does or what you really trying to do.
bstark is offline  
Reply With Quote
Old 10-17-2003, 12:17 PM
#11
 

 
Join Date: Aug 2002
Location: Napa, California
Posts: 7,686

That's very informative bstark.



ashawley is offline  
Reply With Quote
Old 10-17-2003, 12:22 PM
#12
 
Senior Lounger
 
Join Date: Sep 2003
Location: UK
Posts: 210

Thanks for the tip Adam
Kee-Lo is offline  
Reply With Quote
Old 10-17-2003, 12:24 PM
#13
 
Official Shortbus Driver
 
Join Date: Oct 2003
Location: BC
Posts: 82

Quote:
Originally posted by theChronic
strange - i thought that is what you meant, but when i uncheck that top checkbox (leaving only the 'match checked songs only' selected) the 'ok' button greys out. I can only get it to re-enable by checking that top checkbox. . .
Noone else has this problem with the 'OK' button greying out if you don't have the top checkbox selected?
theChronic is offline  
Reply With Quote
Old 10-17-2003, 12:32 PM
#14
 

 
Join Date: Aug 2002
Location: Napa, California
Posts: 7,686

hehe, theChronic, I'm super sorry. T'was late last night and I don't know what I was thinking.

You're absolutely right. You have to have something checked. I'm not at home now, so I don't know what I did, but I think I checked the "Limit" box and set it to a really high value (larger than my library) like 100GB.

Then the OK button is available.

The key, is when you look at your Library (the # of songs) should be the same as the # of songs on this playlist.

Adam



ashawley is offline  
Reply With Quote
Old 10-17-2003, 01:12 PM
#15
 
Junior Lounger
 
Join Date: Aug 2003
Posts: 63
<cntrl>-click -- What's that?

I was trying to follow you Adam but have no idea what you mean by <cntrl>-click .
Thanks.
rcwoll is offline  
Reply With Quote

Topic: A Tip for Syncing With a Library Larger Than iPod

Reply Thread Tools Topic Search

Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





View iLounge History. Read our old Forums Archive (2001-2003)
All times are GMT -4. The time now is 03:59 AM.


Shop for Accessories: Cases, speakers, chargers, etc.