7th Gen Ipod nano not displaying album artwork - iLounge Forums
Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.

Topic: 7th Gen Ipod nano not displaying album artwork

Reply Thread Tools Topic Search
 
Old 12-14-2017, 05:15 AM
#1
 
Junior Lounger
 
Join Date: May 2012
Location: australia
Posts: 29
7th Gen Ipod nano not displaying album artwork

Artwork in my itunes library is perfect, but recently when i load songs on to my ipod nano 7 gen , not all album artwork is dispalyed , very frustrating , have restored to no avail
angelo is offline  
Reply With Quote
Old 12-14-2017, 11:34 AM
#2
 

 
Join Date: Apr 2006
Location: Arizona
Posts: 8,980

If you manually sync, you need to be sure your artwork is embedded in the files (added via the Get Song Info window) because the database of automatically downloaded art is not transferred with manual management. A Smart Playlist can be used to find the ones without embedded art.

File->New->Smart Playlist
Has Artwork is false.
Call it MissingArt

You may want to select all tracks and create a new playlist called Updated so you know what was changed. As you fix the art problem they will automatically fall out of the MissingArt playlist.

Once done, you then should remove the tracks in the Updated playlist from the iPod, and put them back on.



Have you backed up your iTunes Library this week? If not, you are risking losing your music and playlists....
cjmnews is offline  
Reply With Quote
Old 12-16-2017, 10:13 PM
#3
 
Junior Lounger
 
Join Date: May 2012
Location: australia
Posts: 29

Thanks , tried the smart playlist option but did not get many results , ipod classic 7 gen show all artwork and is synched auto , but i make playlists for my ipod nano manually manged , that is i guess where the problem is
angelo is offline  
Reply With Quote
Old 12-16-2017, 10:37 PM
#4
 
Junior Lounger
 
Join Date: May 2012
Location: australia
Posts: 29

artwork that is manually inserted into itunes library from google images etc are not being transfered to ipod nano , only artwork that was automatically gained by itunes shows up , i make my own playlists and transfer to ipod nano . This is a new problem possibly or coincidently with new apple ios update , before everything was ok .
angelo is offline  
Reply With Quote
Old 12-17-2017, 03:02 PM
#5
 

 
Join Date: Apr 2006
Location: Arizona
Posts: 8,980

That is odd. The artwork you add manually is embedded in the file. So if you have a recent copy of the file (hence the remove and re-add) then you get the artwork on the iPod even with manual sync.

The automatically downloaded artwork does not get synced unless you use auto sync.

iOS is getting a bit worse for syncing. The last few versions you have to sync twice to get updates to your smart playlists. The first sync copies the updates to the iTunes. Then iTunes updates the playlists, but too late for the sync to put those updates onto the iOS device. This is why the second sync is needed.

You are seeing the opposite of what is normal. Are you sure?



Have you backed up your iTunes Library this week? If not, you are risking losing your music and playlists....
cjmnews is offline  
Reply With Quote
Old 01-01-2018, 09:39 PM
#6
 
Junior Lounger
 
Join Date: May 2012
Location: australia
Posts: 29

still problem occurs , will try sync twice .
angelo is offline  
Reply With Quote
Old 01-05-2018, 04:46 AM
#7
 
Freshman Lounger
 
Join Date: Jan 2018
Posts: 3

same problem too
Budi Setiawan is offline  
Reply With Quote
Old 01-19-2018, 07:06 PM
#8
 
Junior Lounger
 
Join Date: May 2012
Location: australia
Posts: 29

Have tried re synch but still no good , since this problem has only started occuring with latest update , put it down to that , maybe it will be fixed next update , lol
angelo is offline  
Reply With Quote
Old 01-20-2018, 11:57 AM
#9
 

 
Join Date: Apr 2006
Location: Arizona
Posts: 8,980

I guess I still have to ask, if you are sure that the artwork is embedded inside of the song?

If you play a song with a non-iTunes player, configured NOT to get art automatically from the web, does the art work show up?
If not, then your art is not embedded, and you'll need to fix that for manual management to show artwork.

If so, then I would have to suspect that an old version of the music without the art is on the iPod, and you'll need to delete the songs from the iPod and add them back on to get the new version that has the embedded art.

The other option is automatic sync which will pull the iTunes database of artwork in, and you can have non-embedded art showing on your iPod.



Have you backed up your iTunes Library this week? If not, you are risking losing your music and playlists....
cjmnews is offline  
Reply With Quote

Topic: 7th Gen Ipod nano not displaying album artwork

Reply Thread Tools Topic Search

Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



RSS Feed Widget

iLounge Weekly
News, reviews, articles, giveaways, deals, and more delivered to your inbox.
Sign up for the iLounge Weekly Newsletter

iLounge is an independent resource for all things iPod, iPhone, iPad, and beyond.
iPod, iPhone, iPad, iTunes, Apple TV, Mac, and the Apple logo are trademarks of Apple Inc.
iLounge is © 2001 - 2016 iLounge, Inc. All Rights Reserved. Terms of Use | Privacy Policy