Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.

Topic: Songs don't show up under artists on iPod

Reply Thread Tools Topic Search
 
Old 02-02-2008, 12:00 PM
#1
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8
Songs don't show up under artists on iPod

I have songs on itunes ex. interstate love song by stone temple pilots, and it shows up fine on itunes. but on my ipod i go to stone temple pilots from artists and the song isnt there. i have 2 go to songs to find it, and when i play it, it says the artist is stone temple pilots, so i dont understand why i cant find it without going into the whole songs list. i have this problem with more than 1 song.
blacksabbath69i is offline  
Reply With Quote

Join the iLounge Community and the ad above will disappear.

Old 02-02-2008, 12:14 PM
#2
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,144

Hi and welcome to iLounge.

The usual reason for this is that those tracks are set as "Part of a Compilation" in iTunes, and you have the compilations grouping setting enabled on the iPod. Sometimes the information in CDDB when you rip a CD will have the "Compilation" flag set incorrectly, and this sometimes also happens with content from the iTunes Store.

Generally, the "Part of a Compilation" flag is used for albums that have different artists, so if all of the tracks on your album are by the same artist name, you might just want to disable this setting for those tracks. You can do this by going into iTunes, selecting all of the tracks, and choosing File, Get Info, and then setting "Part of a Compilation" to "No." These tracks should then show up under their proper artists.

The other option is to turn OFF the "Compilations" setting on the iPod itself. For the pre-2007 iPod models, this was found under Settings, Compilations on the iPod. For the 2007 iPod classic and nano, it's controlled by whether or not you have the "Compilations" menu set to display under either the Settings, Main Menu or Settings, Music Menu options.



Jesse Hollington is offline  
Reply With Quote
Old 02-02-2008, 12:31 PM
#3
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

The compilations was already set to off on my ipod and itunes, and the songs are still not showing up under the right artists. could there be any other reasons for this problem??
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 12:35 PM
#4
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,144

Is the compilation setting set to "Off" on the track or on the device?

Does the artist actually show up in the artist listing in iTunes? If it's showing up there and not on the iPod, then it still seems the compilations setting is the most likely cause of this. Since iTunes and the iPod have distinct settings for whether tracks are grouped as part of a compilation, it's possible for the artist to show up properly on iTunes but still not appear properly on the iPod itself.



Jesse Hollington is offline  
Reply With Quote
Old 02-02-2008, 12:43 PM
#5
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

its set to off on both. for example, i have other songs by stone temple pilots, and on itunes the "interstate love song" is with all the other stp songs, but on my ipod, the song doesnt show up under the artist. i dont know why it shows up in the songs but not in the artist.
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 12:52 PM
#6
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,144

Hmm, that is strange, as the "Compilations" flag is generally the only standard cause of this problem.

Have you tried removing the song from the iPod and transferring it back on?



Jesse Hollington is offline  
Reply With Quote
Old 02-02-2008, 12:55 PM
#7
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

ive synced the ipod several times but it still has the problem, im not exactly sure what u mean, how 2 remove it from the ipod.
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 02:49 PM
#8
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,144

Resyncing, unfortunately, does not necessarily recopy the track if it's already there.

To remove a track and re-add it, the simplest way if you are using automatic sync of your entire library is to set your iPod to "Sync only checked items" (you can find this setting on the Summary page of your iPod within iTunes), and then UNcheck the specific track you want to remove.

Once you've done this, sync your iPod and that track should be removed. RE-check the track and sync again, and iTunes will transfer is back onto your iPod.



Jesse Hollington is offline  
Reply With Quote
Old 02-02-2008, 03:05 PM
#9
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

i did that also, and it still doesnt show up under artists. this is very wierd and frustrating, it doesnt make sense.
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 03:45 PM
#10
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,144

Well, make absolutely certain that the artist name is filled out correctly and matches the other tracks by the same artist -- check both the Album Artist and Artist fields to ensure that they're the same.

Also check the specific track that is not appearing just to make absolutely certain that "Part of a Compilation" is not checked (it appears as a checkbox in the bottom right corner of the "Info" tab when viewing the track properties in iTunes -- down by the "Genre" section). It seems like this is acting as it would for a track that is flagged as "Part of a Compilation" so even if this setting is not checked, it might be worth putting a checkmark in that box, saving the track info, and then going back and clearing it, just to make sure that the setting is applied properly.



Jesse Hollington is offline  
Reply With Quote
Old 02-02-2008, 07:06 PM
#11
 
Freshman Lounger
 
Join Date: Nov 2007
Posts: 2

I wonder if I might ask for help on a similar subject. Much of my iTunes Library is made up of entire albums. However, there are a few artists that may be new, or I only like a little bit, from whom I have imported perhaps 1-5 songs. I didn't want these "non-albums" disrupting my lovely coverflow on my new iPod classic, so I would mark them all as compilations.

However, this means that similarly to the user above, I can't access that "awesome new band" via the Artists menu on iPod. Is there a way to display ALL artists on my iPod without spoiling coverflow with EPs and countless singles devoid of artwork?

Many thanks in advance
Eduardo87 is offline  
Reply With Quote
Old 02-02-2008, 08:23 PM
#12
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

i've checked a thousand times, and i am absolutly certain that the song is not flagged as part of a compilation. i dont know if its a glitch in the software, but it most certaintly isnt part of a compilation. i dont possibly know what the problem could be.
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 08:30 PM
#13
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

the song didnt have an album artist, so i put in the correct album artist and synced my ipod, but the problem remains the same. i was hoping so much that that would be the solution, guess not .
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 08:44 PM
#14
 
Freshman Lounger
 
Join Date: Feb 2008
Posts: 8

i figured it out. this particular song didnt have any album info, so the album column was blank. i entered the correct album and synced my ipod, and it showed up. i dont know why this song required album info 2 show up in artists, because i know for a fact there are other songs i downloaded that dont contain the album info that show up under artists, but at least its fixed . thank u jhollington for all of your help.
blacksabbath69i is offline  
Reply With Quote
Old 02-02-2008, 11:18 PM
#15
 

 
Join Date: May 2003
Location: Tiskilwa, IL
Posts: 10,131

Quote:
Originally Posted by blacksabbath69i
i figured it out. this particular song didnt have any album info, so the album column was blank. i entered the correct album and synced my ipod, and it showed up. i dont know why this song required album info 2 show up in artists, because i know for a fact there are other songs i downloaded that dont contain the album info that show up under artists, but at least its fixed . thank u jhollington for all of your help.
The no album info rears it head the most when you have say on album, and a bunch of songs with no album. It seems to not be a problem if you have two albums, and some songs without. Which may explain the differences across multiple artists.




5G 80GB iPod / iPhone 4 / MacBook Pro / Last.fm /
Links to common ?'s
FAQS | Artist missing songs | iPod not Recognized Mac or PC | disable auto-sync temp. | Disk mode How to | iPod has Folder/!
studogvetmed is offline  
Reply With Quote

Topic: Songs don't show up under artists on iPod

Reply Thread Tools Topic Search

Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





View iLounge History. Read our old Forums Archive (2001-2003)
All times are GMT -4. The time now is 02:54 AM.


Shop for Accessories: Cases, speakers, chargers, etc.