Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.

Topic: Problem sending email via Wi-fi

Reply Thread Tools Topic Search
 
Old 04-15-2011, 11:54 AM
#1
 
Freshman Lounger
 
Join Date: May 2004
Location: Boston
Posts: 16
Problem sending email via Wi-fi

I am able to send email within seconds when I'm connected through 3G. Back when I had the 1st gen iPhone, I was able to send on the Edge network. But with both phones, I've never been able to send email when I'm connected through Wi-Fi to any network (home, work, coffee shop). Receiving mail works, as well as other Web functions. I just cannot send email, and in the rare case where it does work, it's taken literally hours for a short email to send.

I used to think this was a weird phone thing and just ignored the problem since I always had the phone's network to do the job. But just last week I got an iPad and the exact same thing is happening--can't send through Wi-Fi--and with my iPad, I don't have the option of 3G.

Why is it that it's only sending mail that won't work, and only with Wi-Fi? I've configured the setting according to my web host's specifications.



Kara
kglinnen is offline  
Reply With Quote

Join the iLounge Community and the ad above will disappear.

Old 04-15-2011, 02:05 PM
#2
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,145

The problem is likely your outbound server configuration on the iPhone and iPad. Most business networks and home ISPs block outbound e-mail on the standard SMTP port 25 by default, ostensibly to protect against e-mail viruses and spam being sent through their network.

As a result, if you're using port 25 for your Outgoing Mail Server, it's very likely it won't work on just about any Wi-Fi network you're connected to. This isn't specifically an iPhone problem, but is due to the fact that most networks are simply blocking outbound mail in some way.

You can check which port you're using for outbound mail by going into your Settings app, choosing Mail, Contacts and Calendars, selecting your mail account and then choosing "Outgoing Mail Server" near the bottom. This will display a list of outgoing mail servers configured on your device, with the primary server for your account shown at the top.


The primary server is the one used by default, however you can enable alternate servers to be used in the event that the primary server is down or unreachable. Note that you may also see one or more servers here that have been preconfigured by your wireless provider.

Selecting your primary server will show you its configuration details, and you should see a "Server Port" field down at the bottom.


Depending on your mail provider, you may be able to use an alternate port to send mail on. Although you should check your provider's specific instructions, port 587 is commonly used for sending mail from an actual mail app, and as a result will be allowed through many firewalls that block port 25. Technically speaking, port 25 is supposed to be used for server-to-server communications and port 587 for sending from a mail client running on a computer or mobile device; unfortunately many ISPs and mail providers still direct you to use port 25 as that's the older method.

Note that some ISPs and networks will block outbound mail entirely on any port and force you to relay mail through their own servers. This is especially common in business and school networks where an internal e-mail system is in place, but is also the case with some home ISPs. If this is the situation you're in, you may be able to get around it simply by configuring your company's or ISP's outbound mail server as a secondary server in the list using the "Add Server" option.




Last edited by Jesse Hollington; 04-15-2011 at 02:10 PM.
Jesse Hollington is offline  
Reply With Quote
Old 04-15-2011, 03:20 PM
#3
 
Freshman Lounger
 
Join Date: May 2004
Location: Boston
Posts: 16

Thanks for the thorough reply. It helps to hear why this is happening. I did have my primary outbound server set for port 587 at default. Must be that my networks here have issues with both 587 and 25.

Thanks much for your explanation. AT&T, Apple, and my Web hosts weren't half as helpful. Kudos to you.



Kara
kglinnen is offline  
Reply With Quote
Old 04-15-2011, 03:45 PM
#4
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,145

I actually used your question in this week's Ask iLounge column

It is very likely that you won't be able to use any outbound mail server when you're on your work network. Most business networks block ALL outbound mail that isn't routed through the company's own internal mail server, and even sometimes you can't get at that server directly as it's designed to be used by the internal e-mail system (ie, Microsoft Exchange). College and school networks will generally have similar restrictions in place.

For use at home, you should check to see if your home ISP has their own mail server that they expect you to use. Frequently this will be the mail server for your ISP-based account (e.g. if you were on Comcast it would be the server for your comcast.net e-mail address). Configuring this as a secondary mail server may allow you to get around any ports that your ISP is blocking. It's rare that ISPs block 587, but it's not unheard of.

Coffee shop Wi-Fi hotspots should be the most open of all, however, in terms of at least allowing 587 traffic out, although again there are some that only provide web surfing and no access to anything else. However, if you can receive mail on a public hotspot you should also be able to send mail, as long (as you're not using port 25 to do so).



Jesse Hollington is offline  
Reply With Quote
Old 04-15-2011, 04:24 PM
#5
 
Freshman Lounger
 
Join Date: May 2004
Location: Boston
Posts: 16

Nice. I wonder if many others are having this same problem. I haven't heard any complaints from fellow iPhone/iPad owners. Glad you were able to use the topic.



Kara
kglinnen is offline  
Reply With Quote

Topic: Problem sending email via Wi-fi

Reply Thread Tools Topic Search

Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending an email w/ attachment ... always more than one gets sent! Hogster iPhone 2 08-17-2009 05:45 AM
Sending email help NMMI89 iPod touch 0 06-16-2009 03:44 AM
Sending Documents Via Email? cessna1466u iPhone 5 11-06-2008 05:44 PM
Trouble sending email attachments? rachelfran iPod touch 0 02-05-2008 08:27 AM
Problem sending email jwkatz iPhone 0 10-28-2007 04:57 PM




View iLounge History. Read our old Forums Archive (2001-2003)
All times are GMT -4. The time now is 06:22 AM.


Shop for Accessories: Cases, speakers, chargers, etc.