Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.

Topic: Got full bar, 3G icon, but no internet.. can someone explain?

Reply Thread Tools Topic Search
 
Old 09-23-2008, 04:29 AM
#1
 
Junior Lounger
 
Join Date: Feb 2006
Posts: 31
Got full bar, 3G icon, but no internet.. can someone explain?

OK, here's the situation:

IN MANY locations, my iPhone 3G have full bars, 3G icon, and I check email...waiting...waiting.. nothing. Open Safari and try to go to Google.com...waiting..waiting..nothing. I tried to make a phone call, have a friend of mine send SMS (text message) and all goes through just fine. Check Internet again.. nothing.

In my old Sprint Mogul (CDMA), if I got 2 bars or less, Internet is either slow or no Internet. 3 bars or more, got Internet. So it's consistent.

So why my iPhone 3G is not behaving that way. Is the firmware 2.1 just a "smoke" screen to show full bar but actually I only have 2 bars, hence really slow or no Internet connection? I tried this in MANY locations these past 3 days and same thing. ONLY in certain location I get full bars and full 3G Internet access, like right tin the middle of downtown (popular business and tourist spot).

Mind you, even with my old Motorola Startac (circa 1996), voice call still goes through with 2 bars....
lanwarrior is offline  
Reply With Quote

Join the iLounge Community and the ad above will disappear.

Old 09-24-2008, 10:01 AM
#2
 
Junior Lounger
 
Join Date: Dec 2006
Posts: 31

I sometimes have similar problems, I could be online and then it thinks for a bit and says safari cannot bring up the page because it is not connected to the internet... And if I go through a tunnel, where I know I have no reception, I still have full bars showing until I either try to do something, or after a minute it drops to nothing...
Nomenclature is offline  
Reply With Quote
Old 09-24-2008, 02:24 PM
#3
 
Junior Lounger
 
Join Date: Feb 2006
Posts: 31

Anyone else? Or this is related to hardware defect?
lanwarrior is offline  
Reply With Quote
Old 09-26-2008, 04:32 PM
#4
 
Freshman Lounger
 
Join Date: Sep 2007
Posts: 14

This started happening to me as well since updating to 2.1. I'm in Canada, on the Fido network and had quite good connectivity before the 2.1 update.

Now, I almost always have 5 bars, but the internet surfing is VERY spotty! I find that when I switch back to Edge, it seems to work well (but slow). The Wi-Fi works great, and I'm definitely getting more battery life out of it.

Any ideas? Should I go back to 2.0.2 and then re-install 2.1?
FunkyMan is offline  
Reply With Quote
Old 09-26-2008, 05:23 PM
#5
 
Junior Lounger
 
Join Date: Feb 2006
Posts: 31

I had a feeling that the 2.1 update just made the signal bar INACCURATE in terms of data. It really doesn't make sense that I have full bars, good for SMS and voice call, but ZERO Internet signal.

I heard about how the new firmware reduces the 3G radio power and transmission usage, so it could be that this messed up the 3G radio such that sometimes the radio got reduced so much that it transmitted data at much lower speed.

I don't know.. what do you guys think?

I am quite surprised that many people didn't report in this thread. Is anyone else have really good Internet speed ALL THE TIME?
lanwarrior is offline  
Reply With Quote
Old 09-26-2008, 08:06 PM
#6
 
Stoopid Ameican Rednek
 
baggss's Avatar
 
Join Date: Jun 2002
Location: Margaritaville
Posts: 10,149

My internet speed seems to consistently decent with 2 or more bars.






baggss is offline  
Reply With Quote
Old 09-27-2008, 02:21 AM
#7
 
SSMoy
 
Join Date: Dec 2003
Location: Toronto
Posts: 1,103

I get a lot more errors now, network problems can't load page, etc... Mail also takes a very long time to connect every time now as well.



Sources: iPhone 4, 80GB Classic, 4GB 1st gen Nano
Earphones: ADDIEMs, Westone UM3X
kloan is offline  
Reply With Quote
Old 10-06-2008, 12:14 PM
#8
 
Junior Lounger
 
Join Date: Dec 2004
Posts: 52

From Apple's website about the 2.1 update:

"Improved accuracy of the 3G signal strength display"

All it does is improve the display, ie. the number of bars looks better. But like you said, it's more like a "smoke screen."

The actual reception is NOT any better. You can check the real signal strength by going into Field Mode.

On the keypad, dial: *3001#12345#* and then hit call.

You will see in the top left corner instead of the bars, you will be a negative number, the bigger then number the better.

eg. -86 is really good reception. -103 is terrible. Good signal strength will be around -70, -80. Bad signal (when 3G keeps jumping to Edge) is around the -100's.
lancerev08 is offline  
Reply With Quote
Old 10-07-2008, 06:59 PM
#9
 
Freshman Lounger
 
Join Date: Oct 2008
Location: Miami, FL
Posts: 15
Lightbulb

I don't think the bars alone will determine you internet connection. The bars just show how strong the signal between you and the closest tower that you are connected to is.

A really good example of this is when I was at a college football game and had 5 bars and 3g, but the internet was so slow it was unusable. I assume that I was close to a tower, but the tower was overwhelmed with cell phone connections and couldn't provide enough data BW to my phone.
dizzy13 is offline  
Reply With Quote
Old 10-07-2008, 07:21 PM
#10
 
Senior Lounger
 
Join Date: May 2008
Location: Miami
Posts: 165

My internet usually always works.

...after 2.1



Forum Policy - No Soliciting Members or Advertising of other websites, blogs or forums.
TheMBC is offline  
Reply With Quote
Old 10-08-2008, 11:02 AM
#11
 
Junior Lounger
 
Join Date: May 2003
Posts: 27

I've been having a similar problem but my phone will say I have full 3G bars and then later switch to Edge for no apparent reason. I'm sitting int eh exact same spot, not moving, for an hour listening to a lecture. Yet even though I'm in the same place for an hour it throttles between 3G and Edge and both display full bars. The past week or two my iPhone service has been getting worse.

Also got out of the subway and it never picked up a signal today. Had to reset to get a signal. The location I was I ALWAYS gives me full bars but today I had to reset to pickup a signal.

WTF APPLE?
fasheezy is offline  
Reply With Quote

Topic: Got full bar, 3G icon, but no internet.. can someone explain?

Reply Thread Tools Topic Search

Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





View iLounge History. Read our old Forums Archive (2001-2003)
All times are GMT -4. The time now is 06:49 AM.


Shop for Accessories: Cases, speakers, chargers, etc.