::sigh:: Page 2 troubles, redux - iLounge Forums
Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.

Topic: ::sigh:: Page 2 troubles, redux

Reply Thread Tools Topic Search
 
Old 05-13-2011, 01:46 PM
#1
 
Veteran Lounger
 
S2_Mac's Avatar
 
Join Date: Oct 2006
Location: About 3 feet in front of the monitor
Posts: 4,878
::sigh:: Page 2 troubles, redux

Sorry for flogging this (apparently dead) horse, but this is really irritating. Yes, I've posted about this before, and Bob sez, "Works fine for me," but something is still wrong.

The situation: When I click on an orange page number link (in the "vbmenu_control1" section of the dark gray "topic_navigation" box) for a second or third page, the link is malformed and won't allow access to the second page.

The conditions: My "thread display options" are set to "Show Avatars," "Show Signatures," and "Show Images;" Thread Display mode is set to "Hybrid;" and "Number of Posts to Show Per Page" and "Default Thread Age Cut Off" are both set to "Forum Defaults."

My testing: I have duplicated the problem on several computers: Mac OSX 10.4, 10.5, and 10.6, using Safari 4 & 5 and FireFox 3 & 4; Win XP SP2 and 3, using a couple of different IEs and FFs; Win 7 (SP unknown) using using a couple of different IEs and FFs. I created a new account (PlaysInTraffic), gave it the same preferences, and duplicated the problem on a smaller set of Mac and Win platforms. I've used connections supplied by ATT and Comcast; no difference.

An example: Here's a recent thread that has grown to 2 pages (given my settings) -- iPad2 versus PS3 for portable media player. The address of the thread starter post is " "http://forums.ilounge.com/ipad/269232-ipad-2-versus-ps3-portable-media-player-post1404283.html". The Page 2 link I get is this: "http://forums.ilounge.com/ipad/269232-ipad-2-versus-ps3-portable-media-player-2.html#post1404283".

Notice that the fragment identifier in the Page 2 link is the same as the tail of the thread starter's link -- "1404283" This results in the following behavior, every time: 1) The actual "Page 2" listing is served up; great! 2) Then the fragment is processed, and the first page -- the true location of the indicated fragment -- loads. In this example, the page I'm ultimately served is http://forums.ilounge.com/ipad/269232-ipad-2-versus-ps3-portable-media-player-post1404283.html

So...well, maybe I'm actually going nuts, or I've developed some strange RDF of my own ;-) But could someone at least humor the crazy person by attempting to replicate this error? Temporarily set your options to match those I've listed above, and then try to access this link: iPad2 versus PS3 for portable media player, Page 2, and then tell me if your final destination was the actual second page, or if -- like me -- you get dumped back onto the first page.

It's not a huge deal to work around this -- right-click on the link to Copy Link; then paste into the browser's address bar, and peck at the Delete key to remove the fragment identifier (leaving the address http://forums.ilounge.com/ipad/269232-ipad-2-versus-ps3-portable-media-player-2.html); then press Return to send the request to iLounge servers. Not a huge deal, but certainly worthy of being a lowercase pita!
S2_Mac is offline  
Reply With Quote
Old 05-13-2011, 01:55 PM
#2
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,238

Thanks for bringing this up again, as it's definitely something we want to get fixed if we can figure out why it's only affecting certain users.

In my case, when I click the link you've provided -- iPad 2 versus PS3 for portable media player -- I'm seeing the exact same behaviour -- page two comes up, but then shortly thereafter redirects back to page 1.

However, the URL I'm seeing for the page 2 link in that thread is actually iPad 2 versus PS3 for portable media player which is working fine (not the "-2" at the end and the lack of a post anchor fragment).

So the question that we need to figure out is why you're getting a different link that contains a post anchor. I'll definitely investigate further, but wanted to at least respond with the current state of affairs as I see it and let you know that we're on it.



Click the image to open in full size.
Jesse Hollington is offline  
Reply With Quote
Old 05-13-2011, 02:23 PM
#3
 

 
Join Date: Jan 2006
Location: In the Pub
Posts: 5,492

I'm seeing the problem too (on Chrome and IE8), but only when my forum settings are "Hybrid" for Thread Display Mode (I normally use Linear mode). When in Hybrid and I change to page 2 or higher, I can see that the Post # at the top-right header of the top post on the page is always #1 no matter what page I'm on, then it reverts back to page 1. Not sure if that's a clue or just a symptom. In Linear mode the page change "sticks" and the top post number is never #1 beyond the first page.
rockmyplimsoul is offline  
Reply With Quote
Old 05-13-2011, 02:40 PM
#4
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,238

I actually do suspect it's a problem with Hybrid mode, but I can't yet reproduce it here. Still looking into it, however...



Click the image to open in full size.
Jesse Hollington is offline  
Reply With Quote
Old 05-13-2011, 03:06 PM
#5
 
Veteran Lounger
 
S2_Mac's Avatar
 
Join Date: Oct 2006
Location: About 3 feet in front of the monitor
Posts: 4,878

Yeah, I've tried to be quite clear in my posts on this matter that it's an issue with "Hybrid" mode; maybe Bob missed that the first time around. It's something to do with how the php code thinks it needs to treat Hybrid views...it's just not finding the right fragment identifier as it builds the Page 2 links. (If it was Perl I'd love to see the code; feel sorry for those who have to pore over longwinded PHP.) Good luck to the brainiacs!

Anyway, just relieved that someone else can verify the problem; means I can put off signing those self-committment papers for another few days ;-)
S2_Mac is offline  
Reply With Quote
Old 05-13-2011, 03:55 PM
#6
 

 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 13,238

I believe I've found and fixed the problem. It appears to be an issue with hybrid view and the VBSEO plug-in (which is what renders the URLs as text-based thread names instead of simply thread IDs).

The URL for the page link will actually still contain the post anchor as that's a function of the hybrid view. However, VBSEO should no longer misinterpret this as a request to direct the user back to the first page of the thread.

Please test it out and let me know if it's working properly now.



Click the image to open in full size.
Jesse Hollington is offline  
Reply With Quote
Old 05-13-2011, 10:37 PM
#7
 
Veteran Lounger
 
S2_Mac's Avatar
 
Join Date: Oct 2006
Location: About 3 feet in front of the monitor
Posts: 4,878

Seems to be working now ::fingers crossed:: Thanx, Jesse...hope there's a little something extra in your envelope this week ;-)

(LOL -- that plugin name threw me for a loop...I got the "Search Engine Optimization" part, but thought the "VB" stood for ::gasp:: Visual Basic <g> Then I woke up and realized it must be vBulletin.)
S2_Mac is offline  
Reply With Quote

Topic: ::sigh:: Page 2 troubles, redux

Reply Thread Tools Topic Search

Become a member of the iLounge Forums. Register Now!
To start viewing messages, select the forum that you want to visit from the selection below.
If this is your first visit, be sure to check out the Forum FAQ and Forum Policy.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
iTunes Summary Page Troubles cmefli iPod classic & Legacy iPods 4 11-08-2006 12:48 AM
Ear pads, redux tmccartney66 Accessories for iPhone, iPad + iPod 3 03-07-2006 05:55 PM
Mytunes redux? hackysackmaster Mac + PC iTunes Tools 7 12-06-2005 03:04 AM
MyTunes Redux orangesuburban iPod classic & Legacy iPods 1 11-24-2005 02:08 PM
Ice Creme Redux jaypod Accessories for iPhone, iPad + iPod 5 02-20-2004 11:03 PM


RSS Feed Widget

iLounge Weekly
News, reviews, articles, giveaways, deals, and more delivered to your inbox.
Sign up for the iLounge Weekly Newsletter

iLounge is an independent resource for all things iPod, iPhone, iPad, and beyond.
iPod, iPhone, iPad, iTunes, Apple TV, Mac, and the Apple logo are trademarks of Apple Inc.
iLounge is © 2001 - 2016 iLounge, Inc. All Rights Reserved. Terms of Use | Privacy Policy